Ask Your Question
0

timedatectl to adjust date and time

asked 2014-12-10 17:49:59 -0500

Cygniapolis gravatar image

On page 20 of the new F21 System Administrators Guide is how to use timedatectl to adjust the system and hardware clocks. But it gives me an error message saying "Invalid number of arguments."

[root@cygniapolis ~]# timedatectl set-time 2014-12-10 15:40:30 Invalid number of arguments.

What am I doing wrong here? My CMOS battery is dead so until I have it replaced I need to set the clock every time I start up. Thanks.

edit retag flag offensive close merge delete

Comments

1

yes randomuser is right. See more about timedatectl at http://www.maketecheasier.com/timedatectl-control-system-time-date-linux/

pnemade gravatar imagepnemade ( 2014-12-10 22:57:36 -0500 )edit
1

Thanks for reporting @Cygniapolis, and for confirming @pnemade - it'll be fixed soon ( http://da.gd/y8yQ ). If you find more opportunities for improvement in the Guide, feel free to use the link in the Feedback section to file a bug.

randomuser gravatar imagerandomuser ( 2014-12-10 23:08:57 -0500 )edit

Thank you randomuser and pnemade.

Cygniapolis gravatar imageCygniapolis ( 2014-12-11 09:56:54 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-12-10 17:54:08 -0500

try timedatectl set-time "2014-12-10 15:40:30" - with quotes

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-12-10 17:49:59 -0500

Seen: 559 times

Last updated: Dec 10 '14