Ask Your Question
0

Changes to GRUB do not take effect / add "PS/2 Generic Mouse" as input device

asked 2014-12-10 12:04:50 -0500

humanplayer2 gravatar image

updated 2014-12-12 11:40:46 -0500

I'm attempting to get scroll with middle + TrackPoint to work under Fedora 21 on a Lenovo X1 Carbon 2014 to work. Following this answer originating from this blog post I have

  1. created a suitable /usr/share/X11/xorg.conf.d/11-trackpoint-wheel-emulation.conf file and
  2. added psmouse.proto=bare to my GRUB_CMDLINE_LINUX line in /etc/default/grub,
  3. and have run grub2-mkconfig -o /boot/grub2/grub.cfg as root to update grub, and have booted.

However, running xinput I still do not see PS/2 Generic Mouse listed, which I suppose is why the proposed solution has no effect.

My install is clean, though I have just migrated (smoothtly) from Ubuntu, keeping my home folder.

What else can I do in order to add the input device?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-12-12 10:10:13 -0500

humanplayer2 gravatar image

updated 2014-12-12 11:44:08 -0500

I sounds like the changes you made do not take effect. Perhaps you installed using UEFI mode. In that case, as stated here, you need to use a different command to update grub.

In your step 3, you should execute

grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg if you installed in UEFI mode, else

grub2-mkconfig /boot/grub2/grub.cfg if you installed in legacy mode.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-12-10 12:04:50 -0500

Seen: 944 times

Last updated: Dec 12 '14