Ask Your Question

Logitech Performance MX Back/Forward buttons not working with Fedora 21

asked 2014-11-24 18:54:05 -0500

pgrm gravatar image

updated 2014-12-11 07:31:55 -0500


I have F21 workstation version with gnome (all updates installed) - after I upgraded to the beta version, I noticed that my mouse (Logitech Performance MX) had a slight problem - Forward/backward buttons on the mouse didn't work in the browser. I figured this would be a bug and resolved later, but after almost a month it's still not working.

I've installed solaar but that didn't change anything.

running xev and testing the buttons reveals actually, that my forward/backward buttons are the same as scrolling up/down (Buttons 4 and 5). Also another button on the mouse (which I almost never used) is assigned the same value as scrolling horizontally left (Button 6). It worked in the earlier version (F20) and so far worked for me in every other OS I've used with this mouse.

Unfortunately I can't manually define the behavior of the buttons with xbindkeys as they have the same ID as the scrolling buttons. Unpairing and again Pairing the mouse also didn't help.

Any other suggestions where I can have a look? Why different physical buttons on the mouse got assigned the same ID in the OS?


I've updated to the final release today, and have still the same problems. This never happened before on any OS (Ubuntu, Debian; Mac OS X; Windows 7, 8, 8.1; Fedora 20) and I never had to install anything additional, it just worked. It's quite disturbing when I'm browsing.

I secretly hoped, it would fix itself with some update, but as final release is here and the bug still exists,... Any ideas what else I could do?

Update 2:

Should have thought about it earlier, the problem is in Wayland - with Xorg the mouse keys work as expected, so that's a workaround for me for now, but any solution on how to fix this when using wayland? or is it a bug there and nothing I can do?

edit retag flag offensive close merge delete


I have a Anywhere MX and works fine with a fresh install of Fedora 21. (Note, Solaar is not necessary if your usb dongle already registered other mice/keyboards).

alfC gravatar imagealfC ( 2014-12-11 21:17:07 -0500 )edit

Yes it was just one of the other things i tried out, do you use wayland? - because that was my problem, I switched back now and all my problems (including the mouse) are gone

pgrm gravatar imagepgrm ( 2014-12-12 03:00:49 -0500 )edit

@pgrm I have the same problem with my Logitech M560 and Fedora 25. With wayland as the default, using Xorg is not an option. Is there a solution yet?

sthh gravatar imagesthh ( 2017-05-31 14:41:19 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2014-12-11 07:32:46 -0500

pgrm gravatar image

updated 2014-12-11 12:45:45 -0500

Workaround for now - use traditional Xorg desktop instead of wayland, then it works.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2014-11-24 18:54:05 -0500

Seen: 1,230 times

Last updated: Dec 11 '14