Ask Your Question
0

Problem with boot

asked 2014-11-24 05:08:56 -0600

TheDcoder gravatar image

I have this "a start job is running for dev-disk-by/x2**/****"

This is going for like 5 minutes every time i boot fedora, is there a solution for this?

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
2

answered 2014-11-27 03:28:50 -0600

TheDcoder gravatar image

updated 2016-12-10 03:35:46 -0600

Okay, i am writing this because, other people can know what is happening.

First, i deleted my swap partition, and what was happening is that fedora was waiting for the swap partition to appear, by default fedora has a timeout for this, you get the exact time everytime because its predefined.

To prevent this, you can edit the fstab file located in /etc, Now, what fstab does is tell fedora for what partitions are required to boot, SOLUTION: you can delete the line where it says swap in the end of the line, but its risky incase if someting happens, so we put a # infront of that line, # means "ignore it" the use of # is to tell the reader (you) something importent, so fedora ignores that stuff. Hope it helps (link for file example below)

--------------------STRAIGHT-FORWARD SOLUTION HERE--------------------

  1. Open fstab file in /etc in a file editor with root privileges.

  2. Locate the line where it says swap at the end of the line

  3. Put a # infront of that line

  4. Save the file

An example of the edited fstab file can be found here.

edit flag offensive delete link more
0

answered 2014-11-28 20:39:38 -0600

shark gravatar image

All the drives you want to mount ( / or /home etc.,) are present in /etc/fstab. Try editing that file and

  1. delete the entry of the partition you removed
  2. or comment it with # ( this step is recommended , in case you don't do anything stupid)

save the file and run

sudo dracut -f

reboot. now you must be good P.S. please dont delete fedora partitions from other OS. because this is the reason hy your facing the problem

edit flag offensive delete link more
2

answered 2014-11-24 10:18:46 -0600

Brancomat gravatar image

it could be a wrong uid in /etc/fstab or a correct uid for a device not available at boot time

this thread seems relevant:

https://bbs.archlinux.org/viewtopic.php?pid=1375172

(see answers from users koutheir and arno13)

edit flag offensive delete link more

Comments

I dont understand please explain

TheDcoder gravatar imageTheDcoder ( 2014-11-25 00:07:06 -0600 )edit

The "start job" issue you're seeing might be about the system trying (and failing) to mount a specific disk partition. Take a look at your /etc/fstab file and see if you can recognize a line that begins with something matching the uid (or label) after the "dev-disk-by" in your message. Could be a wrong entry or some drive that's not reachable at boot time. DO NOT edit /etc/fstab unless you're absolutely sure of what you're doing.

Brancomat gravatar imageBrancomat ( 2014-11-25 11:16:55 -0600 )edit

I thinks it the swap partition, i deleted it

TheDcoder gravatar imageTheDcoder ( 2014-11-26 00:09:18 -0600 )edit

In that case you might try to comment (i.e. add a trailing #) on the line of fstab that contains "swap" in the second column. Be extra careful, since any mistake in that file could render the system unbootable. Here is a general overview of fstab.

Brancomat gravatar imageBrancomat ( 2014-11-26 07:19:49 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2014-11-24 05:08:56 -0600

Seen: 1,976 times

Last updated: Dec 10 '16