Ask Your Question
1

Multilib version problems installing Steam

asked 2014-11-21 22:41:35 -0500

johntate gravatar image

I am trying to install Steam on Fedora 21, I am getting multilib version problems with libdrm. This was not a problem on Fedora 20, it needs to be fixed but I am asking for a possible workaround. I am trying to use the steam package in the rpmfusion repository.

Here is the output from yum install steam

Loaded plugins: langpacks
Resolving Dependencies
--> Running transaction check
---> Package steam.i686 0:1.0.0.49-1.fc21 will be installed
--> Processing Dependency: libpng12(x86-32) for package: steam-1.0.0.49-1.fc21.i686
--> Processing Dependency: alsa-lib(x86-32) for package: steam-1.0.0.49-1.fc21.i686
--> Processing Dependency: libtxc_dxtn(x86-32) for package: steam-1.0.0.49-1.fc21.i686
--> Processing Dependency: mesa-libGL(x86-32) for package: steam-1.0.0.49-1.fc21.i686
--> Processing Dependency: mesa-dri-drivers(x86-32) for package: steam-1.0.0.49-1.fc21.i686
--> Processing Dependency: nss(x86-32) for package: steam-1.0.0.49-1.fc21.i686
--> Processing Dependency: gtk2(x86-32) for package: steam-1.0.0.49-1.fc21.i686
--> Processing Dependency: libXScrnSaver(x86-32) for package: steam-1.0.0.49-1.fc21.i686
--> Running transaction check
---> Package alsa-lib.i686 0:1.0.28-2.fc21 will be installed
--> Processing Dependency: librt.so.1(GLIBC_2.2) for package: alsa-lib-1.0.28-2.fc21.i686
--> Processing Dependency: librt.so.1 for package: alsa-lib-1.0.28-2.fc21.i686
--> Processing Dependency: libpthread.so.0(GLIBC_2.3.2) for package: alsa-lib-1.0.28-2.fc21.i686
--> Processing Dependency: libpthread.so.0(GLIBC_2.1) for package: alsa-lib-1.0.28-2.fc21.i686
--> Processing Dependency: libpthread.so.0(GLIBC_2.0) for package: alsa-lib-1.0.28-2.fc21.i686
--> Processing Dependency: libpthread.so.0 for package: alsa-lib-1.0.28-2.fc21.i686
--> Processing Dependency: libm.so.6(GLIBC_2.0) for package: alsa-lib-1.0.28-2.fc21.i686
--> Processing Dependency: libm.so.6 for package: alsa-lib-1.0.28-2.fc21.i686
--> Processing Dependency: libdl.so.2(GLIBC_2.1) for package: alsa-lib-1.0.28-2.fc21.i686
--> Processing Dependency: libdl.so.2(GLIBC_2.0) for package: alsa-lib-1.0.28-2.fc21.i686
--> Processing Dependency: libdl.so.2 for package: alsa-lib-1.0.28-2.fc21.i686
--> Processing Dependency: libc.so.6(GLIBC_2.16) for package: alsa-lib-1.0.28-2.fc21.i686
--> Processing Dependency: ld-linux.so.2(GLIBC_2.3) for package: alsa-lib-1.0.28-2.fc21.i686
--> Processing Dependency: ld-linux.so.2 for package: alsa-lib-1.0.28-2.fc21.i686
---> Package gtk2.i686 0:2.24.25-1.fc21 will be installed
--> Processing Dependency: libpangoft2-1.0.so.0 for package: gtk2-2.24.25-1.fc21.i686
--> Processing Dependency: libpangocairo-1.0.so.0 for package: gtk2-2.24.25-1.fc21.i686
--> Processing Dependency: libpango-1.0.so.0 for package: gtk2-2.24.25-1.fc21.i686
--> Processing Dependency: libgobject-2.0.so.0 for package: gtk2-2.24.25-1.fc21.i686
--> Processing Dependency: libgmodule-2.0.so.0 for package: gtk2-2.24.25-1.fc21.i686
--> Processing Dependency: libglib-2.0.so.0 for package: gtk2-2.24.25-1.fc21.i686
--> Processing Dependency: libgio-2.0.so.0 for package: gtk2-2.24.25-1.fc21.i686
--> Processing Dependency: libgdk_pixbuf-2.0.so.0 for package: gtk2-2.24.25-1.fc21.i686
--> Processing Dependency: libfreetype.so.6 for package: gtk2-2.24.25-1 ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-11-22 09:06:30 -0500

I had the same problem earlier when installing libdrm. Likely this is not a problem and can possibly be solved by clearing the cache and updating the system. Try to do that as following.

sudo yum clean all && sudo yum update

If you still have problems. I would suggest installing it individually like sudo yum install libdrm.i686 or sudo yum install libdrm-devel.i686.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-11-21 22:41:35 -0500

Seen: 1,238 times

Last updated: Nov 22 '14