Why is gnome asking for my google password?

asked 2014-11-21 03:31:22 -0500

campino gravatar image


When I work on Fedora 20 with Gnome 3.10.2, a dialog box which asks for my google account password keeps poping up. It's really annoying, imagine you type something, and suddenly there is some dialog box which automatically has the focus, so what ever I just typed ends up in the password field.

Other than that, I am not using Gnome Online Accounts at all, so why does Gnome need my google password in the first place? The only application that is using it is Thunderbird, but Thunderbird can access my google mail just fine. I canceled that dialog or typed wrong passwords a dozen times by now, and still Thunderbird can download new mail from the google servers and I can send mail via google. So I am quite sure that it is not Thunderbird asking for my password.

seahorse shows five entries like "Evolution Data Source 1382045999.22067.4@localhost.localdomain" , I am not using Evolution either (it is not even installed), so I wonder what those are (and if I can delete them without causing any trouble). For all other entries in seahorse, I can tell what it is and it has nothing to do with my google account.

How do I get rid of that dialog box? And, why is gnome asking for my google password if I never asked it to access my google account in any way?

edit retag flag offensive close merge delete



I've had the same annoying dialog box, but in my case was the Gnome Online Accounts. Are you sure this feature is off ?

NickTux gravatar imageNickTux ( 2014-11-21 11:36:35 -0500 )edit

GOA is on, but I am using it for XMPP with empathy only, no google involved.

campino gravatar imagecampino ( 2014-11-21 16:44:42 -0500 )edit

Do you use automatic login for your computer ?

shark gravatar imageshark ( 2014-11-23 07:21:22 -0500 )edit

Try to turn it off and try again. I bet this program asks for the password.

NickTux gravatar imageNickTux ( 2014-11-27 14:08:31 -0500 )edit

I'm having the same problem. GOA pops up every now and then (at least once or twice a day) asking for my Google password. I have to enter it twice, then the popups go away for a while. One possible clue: I do have Google 2FA turned on.
The GOA screen doesn't seem to have any errors on it. I'm running Fedora 21; this was a new install, not an upgrade. I haven't set up email on this computer, just Empathy (which connects to Google ok).

Cranky gravatar imageCranky ( 2014-12-19 09:39:02 -0500 )edit