Ask Your Question

Installing Skype multilib issues

asked 2014-11-08 08:37:19 -0500

I have been trying for a while to install skype on FC20 (fully updated).

Using the tarball I extract it and if ls -l I can see this line:

-rwxr-xr-x. 1 j3frea j3frea 36499124 May 22 18:56 skype

But if I ./skype I get:

bash: ./skype: /lib/ bad ELF interpreter: No such file or directory

Apparently this is because I need to install glibc.i686 (see here).

If I try to install an rpm with # yum install skype- (which I've downloaded from skype's website), yum tries to install the needed glib (and other) packages but I then end up with multilib conflicts:

Protected multilib versions: libwayland-server-1.2.0-3.fc20.i686 != libwayland-server-1.4.0-1.fc20.x86_64
Error: Protected multilib versions: pango-1.36.1-3.fc20.i686 != pango-1.36.5-1.fc20.x86_64
Error: Protected multilib versions: libwayland-client-1.2.0-3.fc20.i686 != libwayland-client-1.4.0-1.fc20.x86_64
Error: Protected multilib versions: glib2-2.38.2-2.fc20.i686 != glib2-2.40.0-1.fc20.x86_64

I've tried to # yum install libwayland-server-1.2.0-3.fc20.i686 to no avail. I'm not sure where to go from here. One thought was that a docker instance may be able to help but I would have to learn how to use docker then. I'm sure there's a better solution. Cursed skype scum

edit retag flag offensive close merge delete


This works really well - what have you done differently?

FranciscoD_ gravatar imageFranciscoD_ ( 2014-11-08 11:04:17 -0500 )edit

Thanks FranciscoD_, I actually disabled the i686 repo sometime ago and totally forgot about it. Problem solved. If you write a solution I'll accept it.

jcuenod gravatar imagejcuenod ( 2014-11-11 01:38:16 -0500 )edit

Converted to answer :)

FranciscoD_ gravatar imageFranciscoD_ ( 2014-11-11 04:30:22 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2014-11-09 06:23:34 -0500

FranciscoD_ gravatar image

Can you please check if your COPR repo file matches what Richard has written here: ? Since you enable both the x86_64 and i386 repos, you shouldn't run into multilib package errors.

edit flag offensive delete link more


Maybe some more explanation would be helpful for posterity, I'll edit when I have chance if you like... Also, how did you figure out I was using gnome3.12?

jcuenod gravatar imagejcuenod ( 2014-11-11 05:02:51 -0500 )edit

answered 2014-11-08 11:29:09 -0500

You maybe forgot to install all necessary tools beforehand.

Try the following commands to install required tools first

yum -y install libXv.i686 libXScrnSaver.i686 qt.i686 qt-x11.i686 pulseaudio-libs.i686 pulseaudio-libs-glib2.i686 alsa-plugins-pulseaudio.i686 qtwebkit.i686

option -y in the yum command says that assume yes for all the question being asked while installation. If you do not prefer that you can remove that and execute the command

Download the .rpm version from Skype website that would be a lot easier to install.

Once you downloaded the .rpm version to your local computer, locate the .rpm version and then move to the directory where downloaded rpm version is

Execute the following command

sudo yum localinstall <skype->

I hope it helps.

edit flag offensive delete link more


Same answer is already posted below. What's the point of creating another post?

sudhirkhanger gravatar imagesudhirkhanger ( 2014-11-08 14:29:30 -0500 )edit

Please point to the already existing answer instead of answering again - we want to cut down on dups :)

FranciscoD_ gravatar imageFranciscoD_ ( 2014-11-09 06:20:24 -0500 )edit

I feel like the explanation of my problem makes clear that I've tried this method and I get stuck when yum/dnf are trying to install the i686 libraries - the relevant output is "Error: Protected multilib version".

jcuenod gravatar imagejcuenod ( 2014-11-11 01:48:22 -0500 )edit

Question Tools

1 follower


Asked: 2014-11-08 08:37:19 -0500

Seen: 620 times

Last updated: Nov 08 '14