Ask Your Question

The selinux, my block internet connection in fedora (mate) 20

asked 2014-11-06 05:02:31 -0500

Nti-nos gravatar image

updated 2014-11-06 12:07:48 -0500

I installed wine in fedora (mate), follow the download and installed the img burn, all good, just made copies of a dvd on the computer and just press a button, do not remember exactly what, a yellow table (top right) and give me two options ignore, I do not remember the other, I closed the table (rather than are figured out 'post had to push ignore), and at the same time I pulled the wireless connection of internet, ANY red (prohibitive) table disappeared and the icon wireless network, but I had internet normally, not simply seemed icon. Some point while trying to restore it through the firewall, tweak some settings and the outcome is not I have no internet. While normally restored the settings in firewall, (observing to live cd) internet no. Ans' I understand, if you reset the firewall as shown here default , (from live cd) will i have to internet, (because so it was when it opened for the first time the firewall), but however much I try I can not get by with anything, so it is now without internet. Please help; Thank you.

edit retag flag offensive close merge delete


So far, I see nothing in your post to explain why you think SELinux is the issue. Are you getting alerts from the troubleshooter? If not, open it up (It should be on the System Menu.) and make sure that it's set to give you alerts. If it wasn't, set it that way. Also, see if there are any alerts listed that haven't been dealt with. If not, SELinux isn't involved in your issue.

sideburns gravatar imagesideburns ( 2014-11-06 15:13:45 -0500 )edit

Thanks for the reply. First, I got notice from selinux (for possible consider some movement of the program - imgburn- as a threat),but i the delete, why the first time i face similar issue. But now, and after this incident I have no internet. Can you recommend a solution, about what I said, because despite persistent efforts I have no result? Τhank you.

Nti-nos gravatar imageNti-nos ( 2014-11-06 17:30:59 -0500 )edit

That alert that you deleted probably told you exactly what was wrong. Now, of course, there's no way of telling. Sorry.

sideburns gravatar imagesideburns ( 2014-11-06 17:33:29 -0500 )edit

sudo ausearch -m avc|audit2why should help. I advise you to use applications already in the Fedora repos, especially for such common tasks as burning disks; they generally don't have these problems. sudo fixfiles onboot will relabel on next reboot, a good idea for troubleshooting.

That said, an ingored SELinux warning probably did not kill your networking. Please try to provide more information about the network problem. Update your question with the output of these commands:

  • ip addr
  • ip route
  • ping &ltip address of default route>
  • dig
randomuser gravatar imagerandomuser ( 2014-11-06 17:44:30 -0500 )edit

Thank you, randomuser; live and learn. Nti-nos, you might also want to try this: ping and see if you get any results other than No route to host.

sideburns gravatar imagesideburns ( 2014-11-06 18:03:22 -0500 )edit

1 Answer

Sort by » oldest newest most voted

answered 2014-11-06 18:57:08 -0500

Nti-nos gravatar image

Thank you Exactly, if I had fucked you ignore the question has expired

Results of Performance

[root@localhost ~]# sudo ausearch -m avc|audit2why unable to open (null): Εσφαλμένη διεύθυνση (Incorrect address)

[root@localhost ~]# ip addr 1: lo: <loopback,up,lower_up> mtu 65536 qdisc noqueue state UNKNOWN group default link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00 inet scope host lo valid_lft forever preferred_lft forever inet6 ::1/128 scope host valid_lft forever preferred_lft forever 2: p2p1: <no-carrier,broadcast,multicast,up> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000 link/ether bc:ae:c5:6d:4a:09 brd ff:ff:ff:ff:ff:ff 3: wlp0s29u1u1u4: <no-carrier,broadcast,multicast,up> mtu 1500 qdisc mq state DOWN group default qlen 1000 link/ether 74:ea:3a:8f:12:9c brd ff:ff:ff:ff:ff:ff [root@localhost ~]# ip route [root@localhost ~]# ping <ip address of default route> -bash: syntax error near unexpected token `newline' [root@localhost ~]# dig</no-carrier,broadcast,multicast,up></no-carrier,broadcast,multicast,up></loopback,up,lower_up>

; <<>> DiG 9.9.4-P2-RedHat-9.9.4-15.P2.fc20 <<>> ;; global options: +cmd ;; connection timed out; no servers could be reached [root@localhost ~]#

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2014-11-06 05:02:31 -0500

Seen: 431 times

Last updated: Nov 06 '14