Ask Your Question

How to see Desktop files and folders ?

asked 2014-10-20 07:58:51 -0500

priya gravatar image

updated 2014-10-20 13:30:59 -0500

mether gravatar image

How to see Desktop files and folders ? I can't any icon or folders and files how to show them ?

edit retag flag offensive close merge delete


The new gnome doesn't allow to create icons/files or folders on the desktop.

anishjp gravatar imageanishjp ( 2014-10-20 08:27:50 -0500 )edit

Why ? It's too difficult to manage files and folders on Desktop!! How to enable this feature without installing any tool ?

priya gravatar imagepriya ( 2014-10-22 01:08:08 -0500 )edit

With the new Gnome, it is not possible to add files/folders to the desktop with out installing a tweak tool. If this really bothers you, then you might want to try a different desktop manager like KDE or XFce...

anishjp gravatar imageanishjp ( 2014-10-22 02:55:51 -0500 )edit

Really ? What if I say it's possible and I have done it without installing a single thing?

priya gravatar imagepriya ( 2014-10-22 09:12:02 -0500 )edit

Then tell us how. I think the this particular setting is a dconf setting which you could also change using the terminal or using dconf-editor.

cgonz31 gravatar imagecgonz31 ( 2014-10-22 11:06:49 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted

answered 2014-10-20 09:50:17 -0500

cgonz31 gravatar image

Use the GNOME Tweak Tool:

sudo yum install gnome-tweak-tool

Open the Tweak Tool by typing "tweak" in the Applications search box. Go to "Desktop" and enable "Icons on Desktop." You should now be able to control the desktop as you would for any other folder.

You can look around the Tweak Tool. It's got some other useful things you can change...

edit flag offensive delete link more


Can I do this without this tool ?

priya gravatar imagepriya ( 2014-10-22 01:09:12 -0500 )edit

Why is installing the Tweak Tool a problem for you?

cgonz31 gravatar imagecgonz31 ( 2014-10-22 11:08:00 -0500 )edit

Actually I don't believe doing things automatically, By that I can't learn anything, That's as much as possible I always try to do things manually, I can learn lots of thing by this way!!

priya gravatar imagepriya ( 2014-10-22 13:30:17 -0500 )edit

answered 2016-05-26 15:01:04 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

For the next person who stumbles here:

From the command line, to turn on desktop icons:

gsettings set org.gnome.desktop.background show-desktop-icons true

To turn them off:

gsettings set org.gnome.desktop.background show-desktop-icons false

Once you have enabled them, it is worth noting that [Ctrl] + [Alt] + D can be used to show or hide the desktop.

edit flag offensive delete link more


Thank you!! This is exactly what I was looking for.

computer_freak_8 gravatar imagecomputer_freak_8 ( 2017-05-16 14:11:41 -0500 )edit

answered 2017-11-22 15:03:11 -0500

vulpesVelox gravatar image

I installed Fedora just a few hours ago, and as such I'm as green as they come in terms of Linux software; here's my question:

While I don't mind having to install a tweak tool, I find it a bit strange that the desktop is "off limits" for the user. In fact, I think it's a critical waste of space, lest we forget that it's more ergonomically sound to have ones favourite programmes handy and ready. I suppose there might be some logic explanation, but instead of mucking about, thinking about the why's and the why not's, I'll simply ask you lot.

I've tried the above mentioned method, and thus far I've managed to apply a bin, a home file and a note, that I've previously saved to the folder, paradoxically dubbed "Desktop". However, what I really wanted to do was add a few shortcuts to the desktop, mainly the web browser, my notepad icon and last but not least my new and hopefully soon-to-be best friend, the terminal.

Thank you for taking the time to help a hopeless newbie :)

edit flag offensive delete link more

Question Tools



Asked: 2014-10-20 07:58:51 -0500

Seen: 15,112 times

Last updated: Oct 20 '14