Ask Your Question
0

Use Conky to monitor wifi

asked 2014-10-13 23:31:06 -0500

NM5TF gravatar image

updated 2014-10-14 09:25:42 -0500

mether gravatar image

I have installed Fedora 20 recently....liking it so far...except for 1 little problem....

trying to use Conky to monitor system functions...almost everything is working correctly except for monitoring wifi....I have 4 other *nix distros, all Debian based, that I can monitor my wifi correctly using the Conky variable wlan0....however, wlan0 returns nothing in Fedora

I can see my wifi information using the GKrellm monitor app....it does not list the wifi as wlan0 however, it is listed as wlp0s2flu9

any help would be greatly appreciated...

edit retag flag offensive close merge delete

Comments

after a little more investigation I found what appears to be happening... it seems that the network interface is being renamed at boot...

dmesg | grep wlan0 systemd-udevd[497]: renamed network interface wlan0 to wlp0s2f1u9

now...how do I fix this or prevent it from happening at boot ???

NM5TF gravatar imageNM5TF ( 2014-10-14 10:56:34 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2014-10-15 20:29:32 -0500

mclmmc gravatar image

Another possibility is to use nmcli to identify the device that interests you.

$ nmcli device status
DEVICE    TYPE      STATE        
wlan0     wifi      connected    
cdc-wdm0  gsm       disconnected 
em1       ethernet  unavailable  
lo        loopback  unmanaged

Just create a script to parse...

the terse option is needed in this case.

man nmcli

michele

edit flag offensive delete link more
0

answered 2014-10-14 12:33:17 -0500

NM5TF gravatar image

wellll....

it turns out that my 70+ year old eyes need new glasses....

I was seeing the interface name as wlp0s2flu9 on my screen...

the actual name is wlp0s2f1u9...

changing it to correct version works now

edit flag offensive delete link more
0

answered 2014-10-14 00:14:23 -0500

Rajat gravatar image

gedit ~/.conkyrc

${font}Download: ${totaldown eth0} ${alignr}Upload: ${totalup eth0}

In place of eth0 change wlp0s2flu9 and try.

edit flag offensive delete link more

Comments

thanks for the reply Rajat....

that was the very 1st thing I tried...replacing wlan0 with wlp0s2flu9 still does not work...

I also tried eth0 and every other thing I could think of...

NM5TF gravatar imageNM5TF ( 2014-10-14 10:09:04 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2014-10-13 23:31:06 -0500

Seen: 6,304 times

Last updated: Oct 15 '14