Ask Your Question
0

can`t startx

asked 2014-10-05 10:49:52 -0500

Fedora_linux gravatar image

updated 2015-04-21 09:10:23 -0500

mether gravatar image

Hi! I have many problems in my fedora nothing works :-(

/var/log/Xorg.0.log

[   131.316] 
X.Org X Server 1.16.1
Release Date: 2014-09-21
[   131.316] X Protocol Version 11, Revision 0
[   131.316] Build Operating System:  3.16.3-200.fc20.x86_64 
[   131.316] Current Operating System: Linux localhost 3.12.9-301.fc20.x86_64 #1 SMP Wed Jan 29 15:56:22 UTC 2014 x86_64
[   131.316] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.12.9-301.fc20.x86_64 root=/dev/mapper/fedora-root ro rd.lvm.lv=fedora/swap rd.md=0 rd.dm=0 rd.luks=0 vconsole.keymap=us rd.lvm.lv=fedora/root rhgb quiet LANG=en_US.UTF-8 nouveau.modeset=0 rd.driver.blacklist=nouveau video=vesa:off
[   131.316] Build Date: 03 October 2014  01:18:58PM
[   131.316] Build ID: xorg-x11-server 1.16.1-1.fc21 
[   131.316] Current version of pixman: 0.32.6
[   131.317]    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
[   131.317] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   131.317] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Oct  5 21:10:01 2014
[   131.318] (==) Using config file: "/etc/X11/xorg.conf"
[   131.318] (==) Using config directory: "/etc/X11/xorg.conf.d"
[   131.318] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   131.318] (==) ServerLayout "Default Layout"
[   131.318] (**) |-->Screen "Default Screen" (0)
[   131.318] (**) |   |-->Monitor "Monitor0"
[   131.318] (**) |   |-->Device "Videocard0"
[   131.318] (**) |-->Input Device "Keyboard0"
[   131.318] (**) |-->Input Device "Mouse0"
[   131.318] (==) Automatically adding devices
[   131.318] (==) Automatically enabling devices
[   131.318] (==) Automatically adding GPU devices
[   131.318] (==) FontPath set to:
    catalogue:/etc/X11/fontpath.d,
    built-ins
[   131.318] (**) ModulePath set to "/usr/lib64/nvidia/xorg,/usr/lib64/xorg/modules"
[   131.318] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[   131.318] (WW) Disabling Keyboard0
[   131.318] (WW) Disabling Mouse0
[   131.318] (II) Loader magic: 0x81de40
[   131.318] (II) Module ABI versions:
[   131.318]    X.Org ANSI C Emulation: 0.4
[   131.318]    X.Org Video Driver: 18.0
[   131.318]    X.Org XInput driver : 21.0
[   131.318]    X.Org Server Extension : 8.0
[   131.323] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_32
[   131.326] (--) PCI:*(0:1:0:0) 10de:0a29:104d:9067 rev 162, Mem @ 0xe2000000/16777216, 0xd0000000/268435456, 0xe0000000/33554432, I/O @ 0x0000d000/128, BIOS @ 0x????????/524288
[   131.326] (WW) "glamoregl" will not be loaded unless you've specified it to be loaded elsewhere.
[   131.326] (II) "glx" will be loaded by default.
[   131.326] (II) LoadModule: "glx"
[   131.326] (II) Loading /usr/lib64/nvidia/xorg/libglx.so
[   131.337] (II) Module glx: vendor="NVIDIA Corporation"
[   131.337]    compiled for 4.0.2, module version = 1.0.0
[   131.337]    Module class: X.Org Server Extension
[   131.337] (II) NVIDIA GLX Module  343.22  Thu Sep 11 ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-10-05 12:39:12 -0500

cobra gravatar image

The problem here is that you've got the wrong nVidia video driver package installed, this section of the log is the bit that tells you:

[   131.339] (WW) NVIDIA(0): The NVIDIA GeForce GT 330M GPU installed in this system is
[   131.339] (WW) NVIDIA(0):     supported through the NVIDIA 340.xx Legacy drivers. Please
[   131.339] (WW) NVIDIA(0):     visit http://www.nvidia.com/object/unix.html for more

You should uninstall the nVidia drivers, this should be carried out in a similar way to the one you used to install it. Then you need to install the NVIDIA 340 package. You can install this using any method that is comfortable for you, but the recommended way is as follows:

If you go to http://rpmfusion.org and install their repository on your system (there are instructions linked on the main page) then install the package:

kmod-nvidia-304xx
edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-10-05 10:49:52 -0500

Seen: 2,422 times

Last updated: Oct 05 '14