Ask Your Question
1

No greeter/stuck at boot after installing nvidia proprietary driver

asked 2014-10-03 11:39:40 -0500

jubi-wan gravatar image

updated 2014-10-16 09:15:54 -0500

Hello,

i've got following problem: after installing the nvidia proprietary driver 331 via the yum extender (so dependencies are isntalled automatically aswell) the greeter/the whole displaymanager doesn't load anymore after rebooting. All I can do is go in the ctrl+alt+f2 console and remove the driver via yum, after rebooting then it works again using the nouveau driver. This is how it looks after booting: boot

I am using a laptop with nvidia optimus, the graphicscard is the nvidia geforce gtx 860m. This is the laptop i am using: http://mysn.eu/xmg-c504

I am using korora 20 (a fedora remix) with gnome 3.

Thank you

edit: i should mention that i have similar issues with ubuntu gnome. sing ubuntu gnome, it gets stuck at boot showing only the ubuntu gnome logo. i've read that the recent version of ubuntu in combination of gnome 3 doesnt work with the nvidia proprietary drivers. installing lightdm solved the problem there. didn't try this with fedora 20 yet. is there a possibility to insall xfce completlly so that the greeter aswell is using xfce?

edit2: using lightdm doenst work either. using lightdm, i get stuck at the loadingscreen.

edit retag flag offensive close merge delete

Comments

Why are you using korora with gnome?!?!?

Mehran gravatar imageMehran ( 2014-10-16 11:12:47 -0500 )edit

why not? korora 20 comes with many desktop enviroments, one of them is gnome 3.

jubi-wan gravatar imagejubi-wan ( 2014-10-22 04:26:14 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2014-10-16 09:37:31 -0500

Mehran gravatar image

updated 2014-10-16 09:46:05 -0500

Since you are using a laptop with nvidia optimus, you need to install BUMBLEBEE first. After that you can install the nvidia proprietary driver. The whole process is described bellow:

http://fedoraproject.org/wiki/Bumblebee .

Before that I recommend you to disable secure boot. Additionally Yumex is not a good option here, because there are some dependecies that may not be detected.

edit flag offensive delete link more

Comments

My understanding is that yumex is merely a GUI front-end for yum. If so, it should detect dependencies just as well as yum does. However, I do agree that it's probably best to boot into text mode, use yum to install what's needed then reboot back to a GUI. I'm not sure why, but it seems to work best that way.

sideburns gravatar imagesideburns ( 2014-10-16 14:51:38 -0500 )edit

@sideburns you are right, but sometimes it fails to completely detect dependencies, especialy for proprietary software. I have tested this way many times (for myself and my friends) and it worked nice (except for the first time ;-).

Mehran gravatar imageMehran ( 2014-10-16 17:37:06 -0500 )edit

Thank you; asked and answered.

sideburns gravatar imagesideburns ( 2014-10-16 17:55:04 -0500 )edit

Thanks, it works now though i didn't need to install the proprietary divers since "#yum -y install bumblebee-nvidia" installs them already as far as i understood.

jubi-wan gravatar imagejubi-wan ( 2014-10-22 04:24:49 -0500 )edit

Question Tools

2 followers

Stats

Asked: 2014-10-03 11:39:40 -0500

Seen: 1,269 times

Last updated: Oct 16 '14