Ask Your Question
2

Why do I get a Fedora 22 repository metalink error on my Fedora 20 system?

asked 2014-10-03 06:17:48 -0600

kaf-laarous gravatar image

updated 2014-10-06 12:17:08 -0600

error:
could not parse metalink http://mirrors.fedoraproject.org/metalink?repo=fedora-22&arch=x86_64 error was no repomod file.

Outeput of sudo yum repolise is:

Modules complémentaires chargés : fastestmirror, langpacks, refresh-packagekit Could not parse metalink https://mirrors.fedoraproject.org/metalink?repo=fedora-22&arch=x86_64 error was No repomd file

One of the configured repositories failed (Inconnu), and yum doesn't have enough cached data to continue. At this point the only safe thing yum can do is fail. There are a few ways to work "fix" this:

 1. Contact the upstream for the repository and get them to fix the problem.

 2. Reconfigure the baseurl/etc. for the repository, to point to a working
    upstream. This is most often useful if you are using a newer
    distribution release than is supported by the repository (and the
    packages for the previous distribution release still work).

 3. Disable the repository, so yum won't use it by default. Yum will then
    just ignore the repository until you permanently enable it again or use
    --enablerepo for temporary usage:

        yum-config-manager --disable <repoid>

 4. Configure the failing repository to be skipped, if it is unavailable.
    Note that yum will try to contact the repo. when it runs most commands,
    so will have to try and fail each time (and thus. yum will be be much
    slower). If it is a very temporary problem though, this is often a nice
    compromise:

        yum-config-manager --save --setopt=<repoid>.skip_if_unavailable=true

File /var/cache/yum/x86_64/22/fedora/metalink.xml does not exist

edit retag flag offensive close merge delete

Comments

1

Please explain in a bit detail, what are you trying to do? If you are on Fedora 21, you cannot downgrade to F20 without a fresh install.

anishjp gravatar imageanishjp ( 2014-10-03 06:37:42 -0600 )edit

Thank you anishjp, i'm not sur where i am !

uname -r :
3.16.2-200.fc20.x86_64

but, if i execute yum update for example, the result is:

 ... File /var/cach/yum/x86_64/22/fedora/metalink.xml does not exist
kaf-laarous gravatar imagekaf-laarous ( 2014-10-03 07:28:09 -0600 )edit

Please edit your question and provide us the output of sudo yum repolist. You seem to have enabled some Fedora 22 repository. You are still on Fedora 20 by the way, but if you've installed any packages from this Fedora 22 repository, you may need to remove them. We'll be able to help more once you provide us with the information.

FranciscoD_ gravatar imageFranciscoD_ ( 2014-10-05 04:35:46 -0600 )edit

Thank you FranciscoD_, i'm edit my paste.

kaf-laarous gravatar imagekaf-laarous ( 2014-10-06 12:18:40 -0600 )edit

You have the rawhide repo enabled for some reason. How about the output of grep -n "enabled" /etc/yum.repos.d/*.conf?

FranciscoD_ gravatar imageFranciscoD_ ( 2014-10-06 14:14:13 -0600 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2014-10-16 02:55:19 -0600

FranciscoD_ gravatar image

updated 2014-10-21 17:08:47 -0600

Ah! There you go! Look at the output yourself. You have the rawhide (f22) repos installed. They must've been enabled at some point of time. There's a rpmnew file that indicates that the file has even been modified - you probably disabled it.

Here's what you do:

sudo yum --releasever=20 --disablerepo=* --enablerepo=fedora --enablerepo=updates distro-sync

This should remove the fedora-rawhide packages. If it doesn't, remove them manually and rerun the command. Note that the only repos that you should have enabled are: fedora, updates and rpmfusion (if you use it).

EDIT:

You've been adding and removing repositories randomly. For example, you have packages from the gnome 3.12 repository, but you don't have the repository installed any more. Please be careful when configuring repositories.

At the moment - you need to reinstall the gnome 3.12 repository and run this command:

sudo yum --releasever=20 --disablerepo=* --enablerepo=fedora --enablerepo=updates --enablerepo=<name of gnome 3.12 repository> distro-sync

Replace <name of gnome 3.12 repository> with the actual name of the repository.

Basically, we're disabling all repositories and then selectively enabling the standard Fedora and updates repositories. Now, since you already have packages from the gnome 3.12 repository which are causing issues with the distro sync, you also need to enable it.

Please, be very careful while tinkering with repositories - you need to be absolutely sure of what you're doing! :)

edit flag offensive delete link more

Comments

it doesn't, this is output:

link text

kaf-laarous gravatar imagekaf-laarous ( 2014-10-16 07:29:54 -0600 )edit

Erm. Remove the duplicates, retry and then install these packages manually afterwords.

Is that paste the complete output? It seems to be missing the actual error message. If you piped it to fpaste, you need to use sudo yum --releasever=20 --disablerepo=* --enablerepo=fedora --enablerepo=updates distro-sync 2>&1 | fpaste to make sure stderr is also piped.

Also, I see you have a NetworkManager.x86_64 1:0.9.9.1-4.git20140319.fc20 package, but this version hasn't been pushed to F20 at all - NetworkManager-0.9.9.0-45.git20131003.fc20 has.

Have you been picking stuff from koji manually?

FranciscoD_ gravatar imageFranciscoD_ ( 2014-10-16 09:07:15 -0600 )edit

Try:

LANG=C sudo yum --releasever=20 --disablerepo=* --enablerepo=fedora --enablerepo=updates distro-sync 2>&1 | fpaste

and give us the link please.

FranciscoD_ gravatar imageFranciscoD_ ( 2014-10-16 09:13:39 -0600 )edit

Hello FranciscoD_, this is output: link text

Networkmanager package, I think I've deleted !

kaf-laarous gravatar imagekaf-laarous ( 2014-10-16 10:57:02 -0600 )edit

FranciscoD_, i'm waiting. please .. help me.

kaf-laarous gravatar imagekaf-laarous ( 2014-10-20 13:23:09 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2014-10-03 06:17:48 -0600

Seen: 3,183 times

Last updated: Oct 21 '14