Ask Your Question
1

Has anyone been able to play BBC radio on rhythmbox?

asked 2014-10-03 03:24:15 -0500

FranciscoD_ gravatar image

Hi,

I've been trying to add BBC radio stations to rhythmbox. This link has a list that one can add. Even though I can add them, I cannot play them. rhythmbox tries to search for some package for "mms" but fails.

image description

Checking the properties of the radio station says that it doesn't have a URI handler implemented. Does anyone know if I'm missing packages?

image description

[asinha@localhost  ~]$ rpm -qa \*gstreamer\*
gstreamer1-debuginfo-1.4.1-1.fc21.x86_64
gstreamer1-1.4.2-1.fc21.x86_64
gstreamer1-plugins-base-debuginfo-1.4.1-1.fc21.x86_64
gstreamer1-plugins-good-1.4.2-1.fc21.x86_64
gstreamer1-libav-1.4.3-1.fc21.x86_64
gstreamer-plugins-bad-0.10.23-6.fc21.x86_64
gstreamer-0.10.36-10.fc21.x86_64
PackageKit-gstreamer-plugin-1.0.0-2.fc21.x86_64
gstreamer1-plugins-base-1.4.2-1.fc21.i686
gstreamer1-plugins-bad-free-1.4.2-2.fc21.x86_64
gstreamer-ffmpeg-0.10.13-14.fc21.x86_64
gstreamer1-plugins-base-tools-1.4.2-1.fc21.x86_64
gstreamer-plugins-base-0.10.36-11.fc21.x86_64
gstreamer-plugins-espeak-0.4.0-5.fc21.x86_64
gstreamer1-plugins-ugly-1.4.3-1.fc21.x86_64
gstreamer-plugins-bad-free-0.10.23-24.fc21.x86_64
gstreamer-plugins-ugly-0.10.19-18.fc21.x86_64
gstreamer-plugins-good-0.10.31-13.fc21.x86_64
gstreamer-tools-0.10.36-10.fc21.x86_64
gstreamer-plugins-bad-nonfree-0.10.23-3.fc21.x86_64
phonon-backend-gstreamer-4.8.0-2.fc21.x86_64
gstreamer1-1.4.2-1.fc21.i686
gstreamer1-plugins-base-1.4.2-1.fc21.x86_64
libnice-gstreamer1-0.1.4-4.fc21.x86_64

[asinha@localhost  ~]$ rpm -q rhythmbox
rhythmbox-3.1-1.fc21.x86_64
edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2014-10-06 00:46:36 -0500

TForsman gravatar image

I tested, and I can play radio without any problems. I tested: http://www.bbc.co.uk/radio/listen/live/r1.asx

I wrote about which codecs needs to be installed here: http://www.fedoraonline.se/how-to-make-totem-to-play-mp4v-avi-or-mkv-files/

You need to enable rpm fusion repository and install codecs. Let’s start with enable rpm fusion repository.

Easiest way to enable nonfree and free repository, is with this command:

su -c 'yum localinstall --nogpgcheck http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm'

Now we can install the codecs to make your system able to play most common movies, radio, music files out there.

sudo yum -y install gstreamer-plugins-bad gstreamer-plugins-bad-free-extras gstreamer-plugins-bad-nonfree gstreamer-plugins-ugly gstreamer-ffmpeg gstreamer1-libav gstreamer1-plugins-bad-free-extras gstreamer1-plugins-bad-freeworld gstreamer1-plugins-base-tools updates gstreamer1-plugins-good-extras gstreamer1-plugins-ugly gstreamer1-plugins-bad-free gstreamer1-plugins-good gstreamer1-plugins-base gstreamer1 lame-libs
edit flag offensive delete link more

Comments

Awesome! I had quite a few gstreamer packages installed, but not all of them. Installing the package set you've suggested gets radio working. I'll go file a bug against package kit - if the codec is available, it should find it.

FranciscoD_ gravatar imageFranciscoD_ ( 2014-10-06 03:05:28 -0500 )edit

Bug filed against packagekit: https://bugzilla.redhat.com/show_bug.cgi?id=1149609

I've also updated the main sticky question on codecs with this information. Thanks again.

FranciscoD_ gravatar imageFranciscoD_ ( 2014-10-06 03:36:32 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2014-10-03 03:24:15 -0500

Seen: 1,162 times

Last updated: Oct 06 '14