Ask Your Question
1

Graphics Driver for my MSI Laptop

asked 2014-10-03 02:51:55 -0500

freddyexpress gravatar image

updated 2014-10-03 03:09:25 -0500

mether gravatar image

Hey,

sorry, Im new to linux and need help. Some days ago I bought a new MSI Laptop (MSI GP60 Leopard Pro Gaming Laptop with i7), which has an Intel Graphics Chip & NVIDIA dedicated Graphics Card, for which I want to install dedicated Drivers. There is no option in the BIOS to select which GPU I want to use.

running the following command:

lspci -nnk | grep "VGA\|'Kern'\|3D\|Display" -A2

gives me the following output:

    00:02.0 VGA compatible controller [0300]: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller [8086:0416] (rev 06)
    Subsystem: Micro-Star International Co., Ltd. [MSI] Device [1462:1113]
    Kernel driver in use: i915
--
01:00.0 3D controller [0302]: NVIDIA Corporation GM108M [GeForce 840M] [10de:1341] (rev a2)
    Subsystem: Micro-Star International Co., Ltd. [MSI] Device [1462:1113]
    Kernel modules: nouveau

Can some one help me please?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2014-10-04 01:47:52 -0500

MrSinaRJ gravatar image

updated 2014-10-04 02:26:19 -0500

Welcome to the world of freedom ;) and you did the best thing that you came to fedora

I'm using GT60 and by default there is no need to do anything, secondary gpu will be on all the time and you can use it like a charm, but if you want to turn it off here is my answer:

It can be turned off like this:

I tried bumblebee project at first, but it didn't help me at all, so I tried a lot more after that until i find the best way to turn this off when I'm on f20, I wrote a service for that and I will tell you step by step so you can do it with no problem at all open your terminal and type the code below:

sudo vi /lib/systemd/system/vgaswitcheroo.service

we use this for making the service file in the given address, now we want to fill it so we can use it, when you enter the code you will see terminal like a notepad to write down things, here what we will write:

[Unit]
Description=Turn discrete graphics off
Requires=sys-kernel-debug.mount
After=sys-kernel-debug.mount

[Service]
Type=oneshot
RemainAfterExit=yes
ExecStart=/bin/sh -c "echo OFF > /sys/kernel/debug/vgaswitcheroo/switch"
ExecStop=/bin/sh -c "echo ON > /sys/kernel/debug/vgaswitcheroo/switch"

[Install]
WantedBy=multi-user.target

now we are ready to tell that the laptop should start this service each time we turn the laptop on, so here is the next step:

sudo  systemctl enable vgaswitcheroo.service

now reboot your laptop and see if the power light will turn white after you see the log in page

if there were any problem post it here so I can help you through this ;)

edit flag offensive delete link more
0

answered 2014-10-03 15:21:48 -0500

Mehran gravatar image

Your laptop has optimus technology so you need to install bumblebee. The following link explains how to do this

http://fedoraproject.org/wiki/Bumblebee .

Additionally, you can install drivers for the integrated graphic using

https://01.org/linuxgraphics/ .

Before that I recommend disabling secure boot in fedora :

  • install mokutil package:

    yum install mokutil
    
  • disable secure boot:

    mokutil --disable-validation
    
edit flag offensive delete link more

Question Tools

Stats

Asked: 2014-10-03 02:51:55 -0500

Seen: 2,531 times

Last updated: Oct 04 '14