How To Get Correct Framebuffer and Display Manager Resolution?

asked 2014-09-29 22:44:32 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

I use Intel onboard graphics, which supports the resolutions of both of my monitors:

  1. VGA LCD Monitor, 1280x1024, shown as VGA1 by xrandr
  2. HDMI LED Television, 1920x1080, shown as HDMI1 by xrandr

Both moitors are plugged in, but the VGA is always turned on when I'm using the computer; the HDMI is only turned on when I want to use the large screen. I can switch from one monitor to the other, but I haven't gotten display on both at the same time, but that is not what I am asking presently, but wouldn't mind knowing how :-)

Here is the problem:

When I boot the computer with only the VGA monitor connected, everything is fine. However, when I have both monitors connected while booting (even when the HDMI monitor is powered off), then plymouth always starts in 1920x1080 resolution. When the boot process has completed and the display manager arrives (GDM), there is nothing/only greyness visible on my 1280x1024 LCD monitor. I can move the mouse way beyond the visible screen and I am able to log in by first hitting enter and then typing my password, but I am unable to see the GDM menu. If I disconnect the HDMI LED monitor, then the screen resolution immediately shrinks to 1280x1024 and all looks fine.

Why can I not boot the computer (and get 1280x1024 resolution) with both monitors plugged in (when the secondary HDMI monitor is not even powered on)? Is there way to tell grub2/the system that the VGA monitor is the default and that the HDMI monitor should only be used when I expressly switch to it? Must I constantly unplug the HDMI monitor when I boot the computer? There has to be a more elegant way to manage a computer with two monitors.

edit retag flag offensive close merge delete

Comments

Hey,

May I know which version of fedora are you using?

Rajat gravatar imageRajat ( 2014-09-30 02:00:04 -0500 )edit

Fedora 20.

pgueckel gravatar imagepgueckel ( 2014-09-30 09:18:01 -0500 )edit

did you try to play with order of display in your /etc/X11/xorg.conf ?

baoboa gravatar imagebaoboa ( 2014-09-30 14:39:03 -0500 )edit

xorg.conf hasn't existed since about Fedora 14 or so ;-) There might be a way to specify a primary monitor in /etc/X11/xorg.conf.d/ but I don't know how to do it. Any ideas? And is this really necessary? Shouldn't the system automatically be able to 'see' that the television (HDMI1) is not even turned on?

pgueckel gravatar imagepgueckel ( 2014-09-30 20:12:31 -0500 )edit