Ask Your Question

rpmfusion on F22 rawhide

asked 2014-09-28 21:48:28 -0500

dverbrugge gravatar image

updated 2015-04-09 19:39:34 -0500

mether gravatar image

When I try to install things I frequently get the following error:

Cannot find a valid baseurl for repo: rpmfusion-free/22/x86_64

What could this be from?

edit retag flag offensive close merge delete


more info need. Are you running rawhide? Did you change rpmfusion configuration?

mether gravatar imagemether ( 2014-09-28 22:27:11 -0500 )edit

Yes, this is in rawhide. I do not believe I changed anything, other than enabling the no free repository awhile back. Is there anything else I can look into for you?

dverbrugge gravatar imagedverbrugge ( 2014-09-29 00:30:30 -0500 )edit

I have edited your question title so that it better reflects your question.

randomuser gravatar imagerandomuser ( 2014-09-30 17:11:26 -0500 )edit

7 Answers

Sort by » oldest newest most voted

answered 2014-10-03 17:56:53 -0500

sergiomb gravatar image

rpmfuison-rawhide (devel) is for to Fedora 21 , rpmfusion not made a branch for F21 (yet) the plan is do it after have infrastructure , so rpmfusion for Fedora rawhide (22) doesn't exist , you may try rpmfusion-rawhide but not sure that akmods will work (because kernel)

edit flag offensive delete link more

answered 2014-09-29 05:11:16 -0500

baoboa gravatar image

updated 2014-09-29 14:38:34 -0500

yum info fedora-release.noarch --disablerepo=rpmfusion*

cat /etc/fedora-release

to check your release version

rpmfusion is up to fedora 21 in devel for now

if you want to switch to rawhide again

and for rpmfusion

yum-config-manager --disable rpmfusion*

yum install

yum install

going back to fedora21 is risky , i will advise you to do a clean install

edit flag offensive delete link more


Entering that into the terminal gives me the following:

yum info fedora-release.noarch
[dverbrugge@localhost ~]$ yum info fedora-release.noarch
Loaded plugins: langpacks
adobe-linux-x86_64                                          |  951 B  00:00     
rawhide/x86_64/metalink                                     |  11 kB  00:00     
rawhide                                                     | 4.2 kB  00:00     

 One of the configured repositories failed (RPM Fusion for Fedora 22 - Free),
 and yum doesn't have enough cached data to continue. At this point the only
 safe thing yum can do is fail. There are a few ways to work "fix" this:

     1. Contact the upstream for the repository and get them to fix the problem.

     2. Reconfigure the baseurl/etc. for the repository, to point to a working
        upstream. This is most often useful if you are using a newer
        distribution release than is supported by the repository (and the
        packages for the previous distribution release still work).

     3. Disable the repository, so yum won't use it ...
dverbrugge gravatar imagedverbrugge ( 2014-09-29 13:31:49 -0500 )edit

you can't fedora21 and rawhide are different branch now

baoboa gravatar imagebaoboa ( 2014-09-29 13:47:54 -0500 )edit

I'm guessing the newer version of rpm will eventually be functional. My options are to do a clean install, or I could have some patience, continue to update things, and ignore rpmfusion until it's ready. Right?

dverbrugge gravatar imagedverbrugge ( 2014-09-29 14:04:55 -0500 )edit

fedora is not a rolling release, when the dev with fedora 21 is done, they are gonna to focus on fedora22 and they are gonna to make change in rawhide which can break temporary your system. rawhide is for testing only.

baoboa gravatar imagebaoboa ( 2014-09-29 14:36:41 -0500 )edit

Ok, thank you!

dverbrugge gravatar imagedverbrugge ( 2014-09-29 14:41:42 -0500 )edit

answered 2015-04-06 07:53:29 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

a sort of solution, is use rpmfusion of f21 on f22 , edit /etc/yum.repos.d/rpmfusion-free, updates etc and replace $releasever with 21 and will work on some packages .

UPDATE : On 29 Apr 2015 was announced RPM Fusion free for F22 but only free , still not have nonfree , which works well with metalink and mirror system


Attention : for who change $releasever with 21, after put back $releasever , needs clean all yum and dnf cache radically (I got problems with it) I recommend :

rm -rf /var/cache/dnf/
rm -rf /var/cache/yum/

RpmFusion F22, only publishes on base, we not have updates nor updates-testing , but without cleaning radically cache yum and dnf will continue using F21 updates.

edit flag offensive delete link more

answered 2015-01-04 12:16:20 -0500

fast_rizwaan gravatar image

4th jan 2015, still no rpmfusion fedora 22 support :(

edit flag offensive delete link more



You are supposed to use the rawhide branch for Fedora 22 since that release doesn't exist yet. Also please don't post comments as answers.

mether gravatar imagemether ( 2015-01-04 13:42:19 -0500 )edit

yeah , rpmfusion still doesn't have support rawhide F22

sergiomb gravatar imagesergiomb ( 2015-01-05 15:23:28 -0500 )edit

to me it doesn't sound good that you can't play mp3 on a nearly in beta release.. in 2015!

fedoraemon gravatar imagefedoraemon ( 2015-04-06 00:26:45 -0500 )edit

answered 2015-04-11 22:03:02 -0500

danofsatx gravatar image

RPMFusion appears to be down at the moment - I've not been able to get to thier main website or mirrorlist since Aoril 7, 2015. I've found a public mirror that is up to date, and they have branches for 22 and rawhide already built.

edit flag offensive delete link more

answered 2015-04-09 05:56:36 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

April 9 2015 , still no support for f22 But if you want to play mp3 or mp4 content , Open it via google-chrome, It is sand-boxed during most installation and has inbuilt protocalls to play mp3 and mp4 content.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2014-09-28 21:48:28 -0500

Seen: 7,154 times

Last updated: May 10 '15