Ask Your Question
0

Cannot pair my Apple Magic Trackpad

asked 2014-09-26 14:11:05 -0500

pierods gravatar image

updated 2014-09-28 17:54:13 -0500

mether gravatar image

I try to pair my Apple Magic Trackpad on Fedora 20 (successfully done on the same machine with Windows, both basic driver and Apple driver), the Bluetooth application finds it, but then asks me to enter a PIN on the mouse.

The PIN options button is disabled (grayed out).

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-09-26 22:35:21 -0500

wapello gravatar image

updated 2014-09-26 22:36:25 -0500

Possibly the agent isn't being started from within Gnome you can pair from command line using

/usr/bin/bluetoothctl

This wiki page explains how to do it on Arch: bluetoothctl

You can try just doing the steps to turn the agent on leave the terminal open, and bluetoothctl still running, then launching gnome bluetooth manager and add it with the gui. That might work, though most likely you will need to follow the entire process.

I have done this on Arch but the process should work for fedora as they both use systemd, and bluetoothctl.

edit flag offensive delete link more

Comments

Great, it worked!

One must only pay attention to keep sliding the finger over the trackpad, otherwise bluetoothctl will complain about a not connceted device, and keeping trying the steps more than once.

pierods gravatar imagepierods ( 2014-09-27 02:42:05 -0500 )edit

Glad it worked, I had to do it for a Magic Mouse on one computer.

wapello gravatar imagewapello ( 2014-09-27 10:13:46 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2014-09-26 14:11:05 -0500

Seen: 1,611 times

Last updated: Sep 27 '14