Ask Your Question
0

Error when trying to update the kernel using yum

asked 2014-09-24 01:43:47 -0500

Geetha gravatar image

updated 2014-10-22 01:21:15 -0500

I am currently using Fedora rawhide i.e., F22. When I tried to update the kernel using "yum update" , the following error is occured :

Error: Package: librtmp-2.4-1.20131205.gitdc76f0a.fc20.x86_64 (@rpmfusion-free-updates/20)
           Requires: libgcrypt.so.11()(64bit)
           Removing: libgcrypt-1.5.3-2.fc20.x86_64 (@anaconda/20)
               libgcrypt.so.11()(64bit)
           Updated By: libgcrypt-1.6.1-7.fc22.x86_64 (rawhide)
              ~libgcrypt.so.20()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

What can I do for this? Please anyone help me to get rid of this problem. Please.

edit retag flag offensive close merge delete

Comments

@Geetha: please use the formatting tools to make your question easier to read. You also need to provide more information with your questions - for example, what Fedora release are you using? Are you on rawhide? If not, why is the rawhide repository enabled? Are you trying to update to rawhide? What are the enabled repositories yum repolist? The more information you provide, the easier it is for people to help. Please try to edit your question summary and provide this information rather than using long comments.

FranciscoD_ gravatar imageFranciscoD_ ( 2014-10-06 08:01:33 -0500 )edit

(Ask Fedora does not use the same style as fedoraforum.org )

FranciscoD_ gravatar imageFranciscoD_ ( 2014-10-06 08:03:14 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2014-10-24 03:04:33 -0500

Geetha gravatar image

updated 2014-10-24 03:46:37 -0500

FranciscoD_ gravatar image

I have tried to remove all the repo files of Fedora20 in my Fedora rawhide (F22) system and able to re-install again. I followed these linux commands to solve my problem :

yum install fedup
yum clean expire-cache
yum update selinux-policy\*
yum repolist
yum-config-manager --disable rpmfusion*
yum install http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-rawhide.noarch.rpm
yum install http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-rawhide.noarch.rpm
setenforce 1
package-cleanup --orphans
package-cleanup --dupes
package-cleanup --oldkernel
package-cleanup --leaves
yum install rpmconf 
yum clean packages
yum-config-manager --enablerepo=rawhide
yum clean metadata
yum clean all
rm -rf /var/lib/rpm/__db*
rpm --rebuilddb
yum check-update
yum search yum-plugin
yum install deltarpm
cd /etc
       ------>  vi yum.conf
               -------> edit that yum.conf file by inserting the below line 
                                   deltarpm=0  

yum update
yum install libreoffice
yum install libreoffice-base
yum update

Finally the system with rawhide repo files got updated successfully !!! I can able to install any packages without error :) Now I am relieve from this great problem !!!!!

edit flag offensive delete link more

Comments

Good to hear. Just noting that quite a few of the commands you've listed here shouldn't be relevant to the issue - For example, you've installed rpmconf but not used it. Similarly, yum search yum-plugin shouldn't do anything, just like disabling deltarpms shouldn't have an effect on dependency resolution. I think your repositories weren't set up correctly and the yum-config-manager commands and installation of the correct rawhide rpmfusion repositories are the ones that particularly fixed the issue.

FranciscoD_ gravatar imageFranciscoD_ ( 2014-10-24 03:49:01 -0500 )edit

(You also installed fedup but didn't use it :P)

FranciscoD_ gravatar imageFranciscoD_ ( 2014-10-24 03:51:42 -0500 )edit
1

answered 2014-09-24 02:33:27 -0500

pnemade gravatar image

updated 2014-09-24 02:34:23 -0500

this should be mirror issue from the configured yum repo. Also, I assume you are actually using rawhide fedora 22 machine. Do following as root user or use sudo

yum clean all

then

yum update

edit flag offensive delete link more

Comments

It again shows the same error.

Geetha gravatar imageGeetha ( 2014-09-24 03:03:29 -0500 )edit

something is wrong with your repo files then. Can you provide complete output of this failure?

pnemade gravatar imagepnemade ( 2014-09-24 03:07:48 -0500 )edit

[root@localhost ~]# yum update Loaded plugins: langpacks, refresh-packagekit fedora/22/x86_64/metalink | 30 kB 00:00
Could not parse metalink https://mirrors.fedoraproject.org/metalink?repo=fedora-22&arch=x86_64 error was No repomd file

One of the configured repositories failed (Unknown), and yum doesn't have enough cached data to continue. At this point the only safe thing yum can do is fail. There are a few ways to work "fix" this:

 1. Contact the upstream for the repository and get them to fix the problem.

 2. Reconfigure the baseurl/etc. for the repository, to point to a working
    upstream. This is most often useful if you are using a newer
    distribution release than is supported by the repository (and the
    packages for the previous distribution release still work).

 3. Disable the repository, so yum won't use it by default. Yum will then
    just ignore the repository until you ...
(more)
Geetha gravatar imageGeetha ( 2014-09-24 03:19:41 -0500 )edit
1

if this is not a rawhide machine then I will suggest simply

yum-config-manager --disable rawhide
pnemade gravatar imagepnemade ( 2014-09-24 04:10:40 -0500 )edit

Is there any way to fix this problem?

Geetha gravatar imageGeetha ( 2014-09-24 04:22:29 -0500 )edit

Question Tools

2 followers

Stats

Asked: 2014-09-24 01:43:47 -0500

Seen: 765 times

Last updated: Oct 24 '14