Ask Your Question
2

Building Geary Fails on WebKitGTK

asked 2014-09-23 03:17:55 -0500

I'm trying to build Geary on fc20 (x86_64). This is the output though:

% ./configure 
cmake version 2.8.12.2
-- The C compiler identification is GNU 4.8.3
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Icon cache will be updated
-- Desktop database will be updated
-- Generated desktop file will be checked for errors
-- Help translations will be generated and installed
-- Found PkgConfig: /usr/bin/pkg-config (found version "0.28") 
-- xgettext found
-- Found Vala: /usr/bin/valac  
-- checking for a minimum Vala version of 0.22.1
--   found Vala, version 0.24.0
-- Found vapigen: /usr/bin/vapigen
-- Unity messaging menu support: OFF
-- Unity launcher support: OFF
CMake Error at src/CMakeLists.txt:498 (message):
  WebKitGTK not installed / unknown version detected

I have WebKitGTK installed:

% dnf info webkitgtk
Installed Packages
Name        : webkitgtk
Arch        : x86_64
Epoch       : 0
Version     : 2.2.7
Release     : 3.fc20
...

I'm not quite sure where to go from here...

edit retag flag offensive close merge delete

Comments

Geary is also already available in the Fedora repositories. Why are you trying to build it? yum install geary is all you need.

FranciscoD_ gravatar imageFranciscoD_ ( 2014-09-23 05:01:38 -0500 )edit

A couple of reasons, the version in the repos is not kept up to date (although I've found a copr that is more up to date, I just don't know how stable it is). There are some things that annoy me about it but as far as email clients go, it most suits my needs so I'm hoping to make some contributions at some point.

jcuenod gravatar imagejcuenod ( 2014-09-23 05:20:24 -0500 )edit

I'd recommend asking the maintainer if you could co-maintain the package and help keep it up to date. Note that as per the Fedora Updates policy, maintainers are discouraged from making major updates to packages for stable releases. Rawhide should, however, have the latest version.

http://fedoraproject.org/wiki/Updates_Policy

FranciscoD_ gravatar imageFranciscoD_ ( 2014-09-23 08:49:31 -0500 )edit

I would consider co-maintaining some time in the future but at this point (considering I'm in the dark just building the package) it's probably preemptive.

jcuenod gravatar imagejcuenod ( 2014-09-24 02:26:56 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2014-09-23 04:21:07 -0500

pnemade gravatar image

you are missing development package webkitgtk3-devel. Install this and configure script can run fine.

edit flag offensive delete link more

Comments

I thought this may be the problem but when I tried installing it I got Error: package webkitgtk3-devel-2.2.2-2.fc20.i686 requires pkgconfig(gtk+-3.0), but none of the providers can be installed. I thought that this was because I'm using gnome3.12 from rhughes' copr. So I found the webkitgtk3-devel in his repo and tried installing it but I received the same Error: package webkitgtk3-devel-2.4.2-1.fc20.x86_64 requires pkgconfig(gtk+-3.0), but none of the providers can be installed

jcuenod gravatar imagejcuenod ( 2014-09-23 05:18:17 -0500 )edit
1

now you need gtk3-devel :)

pnemade gravatar imagepnemade ( 2014-09-23 05:25:00 -0500 )edit

Well that's encouraging (kind of). I had got this far but after gtk3-devel I end up needing a new gdk-pixbuf2 but that install fails because there's an old version (e.g. "file /usr/share/man/man1/gdk-pixbuf-query-loaders.1.gz from install of gdk-pixbuf2-2.30.8-1.fc20.x86_64 conflicts with file from package gdk-pixbuf2-2.30.7-1.fc20.i686") and if I remove the old version it wants to remove a whole bunch of packages that depend on it. So I just assumed I was doing something wrong much earlier on. Is there a way around this problem?

jcuenod gravatar imagejcuenod ( 2014-09-23 06:44:03 -0500 )edit

quick answer, generally gnome developers knows how packages are compatible with each other so they uses particular version for dependent packages. So you need those packges to be prior required for compilation.

pnemade gravatar imagepnemade ( 2014-09-23 07:18:16 -0500 )edit

I think a yum build-dep would come in handy here. The conflict problem should solve itself with an update. (You have two different versions for different archs)

FranciscoD_ gravatar imageFranciscoD_ ( 2014-09-23 08:48:06 -0500 )edit

Question Tools

Stats

Asked: 2014-09-23 03:17:55 -0500

Seen: 512 times

Last updated: Sep 23 '14