Ask Your Question
1

problem updating (kmod-staging)

asked 2014-09-19 09:28:12 -0500

Kronolynx gravatar image

updated 2014-09-19 10:09:31 -0500

mether gravatar image

when i try to update i get the next error, how can i fix it ?

Error: Package: kmod-staging-3.16.2-201.fc20.x86_64-3.16.2-1.fc20.1.x86_64 (rpmfusion-free-updates)
           Requires: kernel-uname-r = 3.16.2-201.fc20.x86_64
           Installed: kernel-3.11.10-301.fc20.x86_64 (@koji-override-0/$releasever)
               kernel-uname-r = 3.11.10-301.fc20.x86_64
           Installed: kernel-3.15.10-201.fc20.x86_64 (@updates)
               kernel-uname-r = 3.15.10-201.fc20.x86_64
           Installed: kernel-3.16.2-200.fc20.x86_64 (@updates)
               kernel-uname-r = 3.16.2-200.fc20.x86_64
           Available: kernel-debug-3.11.10-301.fc20.x86_64 (fedora)
               kernel-uname-r = 3.11.10-301.fc20.x86_64+debug
           Available: kernel-debug-3.16.2-200.fc20.x86_64 (updates)
               kernel-uname-r = 3.16.2-200.fc20.x86_64+debug

I got fedora 20 x64 mate compiz.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2014-09-19 09:51:50 -0500

cobra gravatar image

updated 2014-09-19 09:53:59 -0500

The problem here is that the package you're updating requires kernel with version:

3.16.2-201.fc20.x86_64

But the closest kernel you have installed (and the one you're probably running) is this:

3.16.2-200.fc20.x86_64

You either need to install the right kernel (which doesn't seem to be available from that output, otherwise it would have been grabbed in the update too), or inform rpmfusion of the issue because their package appears to be built against the wrong version of kernel.

It's possible that rpmfusion have missed a rebuild of this package when your kernel was released and applied to your system. I've encountered this before with kmod-nvidia, where the package has just escaped their build cycle. If you go to rpmfusion.org you should be able to raise a ticket with them and point out the problem.

If you want to complete the update for now, add --skip-broken as a command line argument to your yum update line:

yum update --skip-broken

And it should complete but miss out the incomplete package (it'll still whine about it though).

edit flag offensive delete link more
0

answered 2014-09-21 03:15:40 -0500

saurav gravatar image

The kmod-staging package provides staging drivers for the kernel so any version of kmod-staging requires the same version of the kernel. In this case kmod-staging version 3.16.2-201.fc20 requires kernel version 3.16.2-201.fc20. This kernel version is now available in the fedora-updates repository. You can try the following:-

yum clean all
yum update kernel

followed by

yum update kmod-staging

If it does not work, you should check your /etc/yum.repos.d/fedora-updates.repo file to make sure that the lines metalink=https://mirrors.fedoraproject.org/metalink?repo=updates-released-f$releasever&arch=$basearch and skip_if_unavailable=False are present. If it still does not work and you can go without updating the kmod-staging package, you can try:-

yum --exclude=kmod-staging* update

This prevents yum from including packages starting with the name 'kmod-staging' from its operations. You can make this permanent so that yum always exlcudes it by adding the following line to the [rpmfusion-free-updates] section of the /etc/yum.repos.d/rpmfusion-free-updates.repo file:-

exclude=kmod-staging*
edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-09-19 09:28:12 -0500

Seen: 897 times

Last updated: Sep 21 '14