Ask Your Question
1

Yum update not working

asked 2014-09-17 01:41:30 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

Dear Fellows

I am facing this below error. yum update not working

[root@localhost ~]# yum update -y
Loaded plugins: auto-update-debuginfo, langpacks, refresh-packagekit
Unable to send message to PackageKit
adobe-linux-x86_64                                                                                                             |  951 B  00:00:00     
fedora/$releasever/x86_64/metalink                                                                                             |  29 kB  00:00:00     
Could not parse metalink https://mirrors.fedoraproject.org/metalink?repo=fedora-$releasever&arch=x86_64 error was 
No repomd file


 One of the configured repositories failed (Unknown),
 and yum doesn't have enough cached data to continue. At this point the only
 safe thing yum can do is fail. There are a few ways to work "fix" this:

     1. Contact the upstream for the repository and get them to fix the problem.

     2. Reconfigure the baseurl/etc. for the repository, to point to a working
        upstream. This is most often useful if you are using a newer
        distribution release than is supported by the repository (and the
        packages for the previous distribution release still work).

     3. Disable the repository, so yum won't use it by default. Yum will then
        just ignore the repository until you permanently enable it again or use
        --enablerepo for temporary usage:

            yum-config-manager --disable <repoid>

     4. Configure the failing repository to be skipped, if it is unavailable.
        Note that yum will try to contact the repo. when it runs most commands,
        so will have to try and fail each time (and thus. yum will be be much
        slower). If it is a very temporary problem though, this is often a nice
        compromise:

            yum-config-manager --save --setopt=<repoid>.skip_if_unavailable=true

File /var/cache/yum/x86_64/$releasever/fedora/metalink.xml does not exist
edit retag flag offensive close merge delete

Comments

try as a root user yum clean all and use the same command

pnemade gravatar imagepnemade ( 2014-09-17 01:45:17 -0500 )edit
1

It looks like it is passing a literal "$releasever" instead of substutiting '20' for the variable. Have you modified any of the files in /etc/yum.repos.d? man yum.conf has a section on "releasever" that suggests the source of $releasever is /etc/redhat-release or /etc/fedora-release. Have you modified these files?

randomuser gravatar imagerandomuser ( 2014-09-17 08:30:53 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2014-09-17 10:20:26 -0500

baoboa gravatar image

as said $releasever is not defined

first check what's your release

cat /etc/fedora-release

in a new shell ( if you are using fedora 20 ) use this

yum distro-sync --releasever=20

edit flag offensive delete link more

Comments

1

I'd wait for the OP to provide more info before suggesting an answer. Quite a few things could cause yum to not pick releasever correctly.

FranciscoD_ gravatar imageFranciscoD_ ( 2014-09-17 20:35:38 -0500 )edit
0

answered 2014-09-20 23:12:26 -0500

Gaurav Dighe gravatar image

Try below:

sudo yum clean all

and then try

sudio yum distro-sync

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-09-17 01:41:30 -0500

Seen: 5,825 times

Last updated: Sep 20 '14