Ask Your Question
0

NFS mount hangs in rawhide

asked 2014-09-16 22:03:13 -0500

klausi gravatar image

updated 2014-09-18 06:32:01 -0500

FranciscoD_ gravatar image

The nfs mount from the command line takes 1-2 minutes to complete.

Sep 17 04:44:15 rawhide.local kernel: SELinux: initialized (dev 0:36, type nfs), uses genfs_contexts Sep 17 04:44:20 rawhide.local org.gtk.Private.UDisks2VolumeMonitor[2126]: index_parse.c:191: indx_parse(): error opening /media/groucho/nfs/BDMV/index.bdmv Sep 17 04:44:20 rawhide.local org.gtk.Private.UDisks2VolumeMonitor[2126]: index_parse.c:191: indx_parse(): error opening /media/groucho/nfs/BDMV/BACKUP/index.bdmv

There is no BDMV directory.

edit retag flag offensive close merge delete

Comments

The forum cannot support rawhide - we can only support stable versions of Fedora. Please report this to the QA mailing list. Rawhide is for testing only. Cheers.

I'll leave the question open for a bit, but close it in a few days.

FranciscoD_ gravatar imageFranciscoD_ ( 2014-09-18 06:32:42 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2014-09-17 08:41:23 -0500

cobra gravatar image

updated 2014-09-17 08:42:28 -0500

Rawhide is the testing version of Fedora. Have you reported this as an issue to the system maintainers? Fedora 21 will be released very soon, I think they might be keen to hear if you're having nfs and/or selinux problems.

As a workaround, you could consider using the 'soft' option, or changing the 'timeo' value on the the mount line for the drive in fstab.

I moved away from using static mounts and now I use autofs to get user's home directories mounted - it means mount time is not an issue as directories are only mounted when needed. Using that approach might also provide you with a work-around.

edit flag offensive delete link more
0

answered 2014-10-11 00:34:00 -0500

klausi gravatar image

updated 2014-10-11 03:22:27 -0500

Using /export 192.168.1.0/24(rw,no_subtree_check,crossmnt,fsid=0) on the server you have to mount the share with "mount -t nfs4 server-ip:/" instead of "mount -t nfs server-ip:/export"

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2014-09-16 22:03:13 -0500

Seen: 352 times

Last updated: Oct 11 '14