Ask Your Question
1

klavaro crashes

asked 2014-09-11 15:57:12 -0500

Kronolynx gravatar image

updated 2014-09-12 10:55:59 -0500

when i start klavaro it looks like it's starting, the window appears but then in less than a second it vanishes. the customisation i did was to change the font, i have 12 gigas or RAM, klavaro version 2.00

as can be seen in the pastebin i get a core dumped when i run klavaro in the terminal.

http://pastebin.com/DsjaLdx3

any help would be appreciated.

thanks

Ps. I'm running fedora mate 20 x64

edit retag flag offensive close merge delete

Comments

Before anybody can begin to help you, we'll need some more information. What are you doing when it crashes, have you customized the program and how much RAM you have are just a few of the things we'll need. Please edit your question to add this information and anything else you think might be useful because right now, there's nothing to go on.

sideburns gravatar imagesideburns ( 2014-09-11 16:50:11 -0500 )edit

thanks, just added the info, please let me know if there's anything else i could add or do :)

Kronolynx gravatar imageKronolynx ( 2014-09-12 01:29:56 -0500 )edit

Could be a bug. Can you run it from a terminal and see if you get any error messages? Please also update the question to include what version of klavaro you're using.

FranciscoD_ gravatar imageFranciscoD_ ( 2014-09-12 02:10:22 -0500 )edit

thanks, just added the version, the error is core dumped and was already in the post but as a link to paste bin cause it's too long. I guess the core is being dumped cause it's trying to access memory that is not accessible. I would like to know how to completely remove the program then reinstall it, I tried yum autoremove but when i reinstall it still doesn't work.

Kronolynx gravatar imageKronolynx ( 2014-09-12 10:27:52 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-09-12 20:52:40 -0500

FranciscoD_ gravatar image

If it's a bug, you need to file it and wait for upstream or the maintainers to fix it. Isn't abrt catching the crash and filing a bug for you? I don't see an open bug yet.

Reinstalling rarely helps. The system files aren't changing and the bug won't go away with a reinstall. You can try removing the local user files in your home directory - probably in .klavaro or another folder. I'm not sure.

You can investigate further by running it in gdb as explained here: http://fedoraproject.org/wiki/StackTraces

edit flag offensive delete link more

Comments

thanks, i just created an account in bugzilla and let abrt report the bug:

https://bugzilla.redhat.com/show_bug.cgi?id=1141436

I will read later aboyt stacktraces and see what i can find, I tried deleting the .klavaro folder in my home but it didn't work i guess i'll have to wait or may be install another typing program :D

thanks again for the help.

Kronolynx gravatar imageKronolynx ( 2014-09-13 06:46:10 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2014-09-11 15:57:12 -0500

Seen: 165 times

Last updated: Sep 12 '14