Ask Your Question
2

How can I trackdown my Wifi driver issues?

asked 2014-09-06 13:28:08 -0500

John D Giotta gravatar image

updated 2014-09-09 18:59:11 -0500

I run Fedora 20 on my Lenovo Yoga 11s. It's a pretty sweet set up with the exception of wifi driver support. Originally, I started with the rtl8723au driver maintained by lwfinger. Eventually this driver got rolled into the kernel, which I thought "cool, no more compiling" unfortunately it does not work...

To get wi-fi working after a system update, I have to:

sudo modprobe -r r8723au
sudo make install
sudo modprobe 8723au

More details:

$ dmesg | grep rtl
[    3.853303] r8723au: module is from the staging directory, the quality is unknown, you have been warned.
[    3.942272] usbcore: registered new interface driver rtl8723au
[    4.049134] 8723au: module verification failed: signature and/or  required key missing - tainting kernel
[    4.053273] Error: Driver 'rtl8723au' is already registered, aborting...
[ 1112.292773] usbcore: deregistering interface driver rtl8723au
[ 1122.056652] usbcore: registered new interface driver rtl8723au

It appears I'm getting an interface block at boot that prevents the driver from starting.

Even more information:

If I de-register the build-in module then re-register it loads properly... why?

[   76.341159] usbcore: deregistering interface driver rtl8723au
[   78.753944] r8723au: module is from the staging directory, the quality is unknown, you have been warned.
[   78.802122] usbcore: registered new interface driver rtl8723au
[   78.869941] rtl8723au: Loading firmware rtlwifi/rtl8723aufw_B_NoBT.bin

How can I trace the root issue with the driver? I'd hate to blacklist it when it obviously works outside if the kernel version.

edit retag flag offensive close merge delete

Comments

Is it on the blacklist for modprobe? Check /etc/modprobe.d/blacklist.conf.

abadrinath gravatar imageabadrinath ( 2014-09-10 01:17:50 -0500 )edit

No such file.

$ sudo -i $ cat /etc/modprobe.d/blacklist.conf cat: ... No such file or directory

John D Giotta gravatar imageJohn D Giotta ( 2014-09-10 13:21:22 -0500 )edit

In the meantime, I added the deregister/register to a rc.local file

John D Giotta gravatar imageJohn D Giotta ( 2014-09-10 22:16:29 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-09-18 22:21:40 -0500

John D Giotta gravatar image

This is NOT the answer, but at least a work around for users suffering the same issue.

Create a rc.local file in /etc/rc.d/

# vi /etc/rc.d/rc.local

Then enter the following 4 lines:

#!bin/sh
/usr/sbin/modprobe -r r8723au
/usr/sbin/modprobe r8723au
exit 0

Then :wq and reboot

This will de-register and then register the module at boot, forcing the module to load.

I've been running this method for over a week without issue.

edit flag offensive delete link more

Comments

Hallelujah I was scratching my head one for hours. Thankyou. I would just add to run chmod +x /etc/rc.d/rc.local before reboot. Many thanks.

lindsaymacvean gravatar imagelindsaymacvean ( 2014-10-22 20:14:35 -0500 )edit

I'm all about the votes :-)

John D Giotta gravatar imageJohn D Giotta ( 2014-10-25 10:55:58 -0500 )edit

FYI future readers: This worked great for the whole year. I just upgraded from Fedora 20 to 22 and I had to remove this patch to make it work again.

lindsaymacvean gravatar imagelindsaymacvean ( 2015-07-04 10:51:01 -0500 )edit

Question Tools

2 followers

Stats

Asked: 2014-09-06 13:28:08 -0500

Seen: 1,013 times

Last updated: Oct 22 '14