Ask Your Question
1

Why did my games stop working after installing the nVidia drivers?

asked 2014-09-05 06:05:52 -0500

herku1004 gravatar image

updated 2014-09-05 10:47:42 -0500

mether gravatar image

Hello! Previously I could not run Gnome Fedora in my PC because after installation (and many times during it) I would experience severe graphic glitches. Most of the time it would freeze in the easiest tasks and fill the screen with glitched patterns. I tried many versions and eventually I gave up on fedora since in the best case scenario I could surf the web and all the "a" "w" and "q"s would all disappear making any text incomprehensible.

When fedora 20 came out I really wanted to have it, but I had the very same problems when installing the gnome version. Eventually I realized it was probably the motherboard's built-in graphic processor that was incapable of the job, so I installed a GeForce 8400 GS that I had sitting around and VOILA! Fedora 20 was up and running with 0 problems! I was happy as I could be! Eventually I downloaded a nice 3D game to check it's performance and I was amazed it would run. (It used to run much smoother on Windows on this card but it didn't seem like anything to be worried about) I went on and installed Steam to play Monaco, and surprisingly enough, that was playable as well.

However under Details on Graphics it would read Gallium x.x (I can't recall the exact number). I figured that was because I had not yet installed the nVidia driver so I went on and did so hoping that it would maximize my systems performance. After the installation of the driver it now reads: GeForce 8400 GS/PCIe/SSE2. But! Now the little 3D game I had installed doesn't run anymore. A window pops up and immediately closes itself without any error prompting. Monaco does not run either flashing a white box and closing sortly after. The only error showing up seems to be an error about GL not being set in direct rendering mode.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-09-12 08:52:58 -0500

Errors about direct rendering mode usually indicate that the graphics driver you are attempting to use isn't functioning properly. A quick solution would be to uninstall the driver, reboot, and then install the driver again. If you're not using a kmod solution for your driver updates, know that updating the kernel will break your driver installation and you'll have to uninstall the driver, reboot, and reinstall the driver after each kernel update.

Let me know if that doesn't work for you!

edit flag offensive delete link more

Comments

Yes. I guess it is the driver. However, I didn't bother installing drivers manually, and went for easyLife instead. Now I notice that there is no way to uninstall or rollback the driver using this program. Would you mind explaining how to since I'm new to driver management in Linux?

herku1004 gravatar imageherku1004 ( 2014-09-15 06:30:23 -0500 )edit

Well, I've never used easyLife before, and unfortunately I don't have a machine with an nVidia card in it to test with. What I might suggest doing is using easyLife to erase the nVidia driver from your system and then try installing it with RPMFusion's nVidia driver package or simply by acquiring the tarball from nVidia's site. What do you think?

bitwiseoperator gravatar imagebitwiseoperator ( 2014-09-28 10:54:13 -0500 )edit

Question Tools

Stats

Asked: 2014-09-05 06:05:52 -0500

Seen: 2,466 times

Last updated: Sep 12 '14