Ask Your Question
0

Installing skype error

asked 2014-09-01 07:08:43 -0500

dcpust gravatar image

updated 2014-09-02 05:14:19 -0500

Hello, I tried to install skype using this guide: if-not-true-then-false.

This lead to the minor problem of missing libraries when starting the application, so I installed them manually until I came up to this one (error lib):

[root@localhost skype]# skype
/opt/skype/skype: error while loading shared libraries: libQtWebKit.so.4: cannot open shared object file: No such file or directory

I checked where I could find the necessary library:

[root@localhost skype]# yum whatprovides libQtWebKit.so.4
Loaded plugins: langpacks, refresh-packagekit
qtwebkit-2.3.3-1.fc20.i686 : Qt WebKit bindings
Repo        : fedora
Matched from:
Provides    : libQtWebKit.so.4

qtwebkit-2.3.3-3.el7.i686 : Qt WebKit bindings
Repo        : nux-dextop
Matched from:
Provides    : libQtWebKit.so.4

qtwebkit-2.3.3-7.fc20.i686 : Qt WebKit bindings
Repo        : updates
Matched from:
Provides    : libQtWebKit.so.4

I picked the latter one and installed it:

yum install qtwebkit-2.3.3-7.fc20.i686

But the lib error from before (error lib) is persistent.

Then I updated the repos using yum update

The output shows a pretty mess:

Error: Package: vlc-core-2.1.5-2.el7.nux.x86_64 (nux-dextop)
           Requires: libass.so.5()(64bit)
Error: Package: vlc-core-2.1.5-2.el7.nux.x86_64 (nux-dextop)
           Requires: libdvbpsi.so.7()(64bit)
           Available: libdvbpsi-0.2.2-3.el7.nux.x86_64 (nux-dextop)
               libdvbpsi.so.7()(64bit)
           Installed: libdvbpsi-1.1.2-1.fc20.x86_64 (@rpmfusion-free)
              ~libdvbpsi.so.9()(64bit)
Error: Package: ffmpeg-libs-2.3.2-1.el7.nux.x86_64 (nux-dextop)
           Requires: libass.so.5()(64bit)
Error: Package: gstreamer-plugins-ugly-0.10.19-17.el7.nux.x86_64 (nux-dextop)
           Requires: libcdio.so.15()(64bit)
Error: Package: gstreamer1-plugins-ugly-1.2.4-1.fc20.x86_64 (@rpmfusion-free-updates)
           Requires: libx264.so.138()(64bit)
           Removing: x264-libs-0.138-2.20131030gitc628e3b.fc20.x86_64 (@rpmfusion-free)
               libx264.so.138()(64bit)
           Updated By: x264-libs-0.142-7.20140728gitaf8e768.el7.nux.x86_64 (nux-dextop)
              ~libx264.so.142()(64bit)
Error: Package: nux-dextop-release-0-5.el7.nux.noarch (nux-dextop)
           Requires: epel-release
Error: Package: gstreamer1-vaapi-0.5.8-5.el7.nux.x86_64 (nux-dextop)
           Requires: libgstbasevideo-1.0.so.0()(64bit)
Error: Package: python3-speechd-0.8-11.el7.nux.x86_64 (nux-dextop)
           Requires: speech-dispatcher = 0.8-11.el7.nux
           Installed: speech-dispatcher-0.8-9.fc20.x86_64 (@updates)
               speech-dispatcher = 0.8-9.fc20
           Available: speech-dispatcher-0.8-5.fc20.i686 (fedora)
               speech-dispatcher = 0.8-5.fc20
Error: Package: gstreamer-plugins-ugly-0.10.19-17.el7.nux.x86_64 (nux-dextop)
           Requires: libcdio.so.15(CDIO_15)(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

I believe that there is a relation between being unable to execute skype and the list of errors above. Do you agree? How can fix the errors? Or how can I install libQtWebKit.so.4 and get skype running?


As requested, here is the output:

[root@localhost ~]# ldd /opt/skype/skype
    linux-gate.so.1 =>  (0xf7798000)
    libXv.so.1 => /lib/libXv.so.1 (0xf5465000)
    libXss.so.1 => /lib/libXss.so.1 (0xf5461000)
    librt.so.1 => /lib/librt.so.1 (0xf5458000)
    libdl.so.2 => /lib/libdl.so.2 (0xf5453000)
    libX11.so.6 => /lib/libX11.so.6 (0xf5316000)
    libXext.so.6 => /lib/libXext.so.6 (0xf5303000)
    libQtDBus.so.4 => /lib/libQtDBus.so.4 (0xf5283000)
    libQtWebKit.so.4 => not found
    libQtXml.so.4 => /lib/libQtXml.so.4 ...
(more)
edit retag flag offensive close merge delete

Comments

what does ldd /opt/skype/skype show?

pp78 gravatar imagepp78 ( 2014-09-01 12:39:41 -0500 )edit

Hi! try installing skype with https://github.com/kuboosoft/skype-installer

davidva gravatar imagedavidva ( 2014-09-02 21:27:19 -0500 )edit

Is libwayland-server actually installed? If it is, I'd recommend removing it, running yum clean all then try again.

jmcknight gravatar imagejmcknight ( 2014-09-05 01:15:37 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
1

answered 2014-09-01 13:52:03 -0500

n0oir gravatar image
edit flag offensive delete link more

Comments

Microsoft has closed their service for Skype versions < 4.3, so this won't help.

Axel Sommerfeldt gravatar imageAxel Sommerfeldt ( 2014-09-02 02:10:12 -0500 )edit

Tried it - no effect. But thx for the suggestion.

dcpust gravatar imagedcpust ( 2014-09-02 03:58:24 -0500 )edit
1

answered 2014-09-01 18:03:21 -0500

jmcknight gravatar image

updated 2014-09-01 18:14:10 -0500

I see a few problems here. Before anything else -- why are you using the Nux Dextop repository in Fedora? This is a repo for RHEL and given that you're also using RPM Fusion, there are bound to be conflicts as these 2 repositories provide a lot of the same packages such as VLC as shown in your error.

Try disabling one or both of those repos then try yum update again.

edit flag offensive delete link more
1

answered 2014-09-01 13:46:14 -0500

Fox gravatar image

Weird, I installed Skype via the rpm package for Fedora from the offical Site and had no problems, running Fedora 19 but since you allready installed Skype I dont think you want to try this way.

About the libQtWebKit.so.4 error: Normaly all installed lib are found in /usr/lib (32 bit libs) and /usr/lib64 (64 bit libs) so its weird that skype is looking for the lib in /opt/skype/skype. You could try to copy the libQtWebKit.so.4 from the /usr/lib (its there probably in a subfolder, called something like qt, or just use the search to find it faster) folder to /opt/skype/skype

And about the output after you did the yum update: It looks like that some of your Packages need some specifig libs/packages. For example in the first line, vlc-core requires libass.so.5()(64bit) So i would try installing this lib. The same goes for all other libs/packages which are required

edit flag offensive delete link more

Question Tools

Stats

Asked: 2014-09-01 07:08:43 -0500

Seen: 5,440 times

Last updated: Sep 02 '14