Ask Your Question
0

grub rescue windows 8.1 and fedora 20

asked 2014-08-31 11:13:46 -0500

minosys gravatar image

updated 2014-08-31 11:32:36 -0500

mether gravatar image

hello, i recently installed fedora 20 on my toshiba laptop that already has windows 8.1 and UEFI secure boot... it didn't want to boot until i deactivated the secure boot. then i tried making it work with secure boot ON by following a tutorial... but i guess i did something wrong because now it doesn't want to boot and i get the "grub rescue" screen

here's a screenshot image description

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
0

answered 2014-09-19 22:19:06 -0500

SDas gravatar image

You can try out this. Insert the fedora 20 cd and press Esc button a boot prompt will appear then write linux rescue and hit enter, then continue in every appeared menu. After all of this you will get a command prompt, now write the following commands - chroot /mnt/sysimage grub2-install /dev/sda grub2 will be used if your grub version is grub2 and /dev/sda is the boot-loader if you have changed the boot loader then place that device in place of /dev/sda. After installation exit and restart.

edit flag offensive delete link more
0

answered 2014-09-19 01:43:42 -0500

Hi... I have the same problem... Toshiba Laptop, Windows 8.1 Installed, have just installed Fedora 20. Can't access Fedora with Secure Boot mode ON, cant access windows 8.1 too... Cause is giving me the message that something doesn't seem to be "correct" in the hard drive... I can only access Fedora and Windows with secure boot in off mode... Guess if i want to solve the problem for windows i will have to format the partitions with Fedora on windows... I am not going o do that. I'm only thinking in a way that i can fix the boot with Grub, when Toshiba Logo apears it is hard cut by the Linux boot menu... Going to research hw to fix that problem... Umm i think you obviusly know that un many models of toshiba Laptops you can access the bios by pressing the key F2 AND in security options turn off Security Boot... Then you can access linux in your hard drive or with some live DVD... If i know more about this issue i will post again.

edit flag offensive delete link more
0

answered 2014-09-19 10:27:11 -0500

TheDcoder gravatar image

Dual-booting with windows 8.1 is very risky... Your GRUB is Corrupted, windows will not boot but you can boot your fedora, i am not exactly sure it will work but try using a live cd or usb with Super Grub Disk and burn it to a cd and boot it.. if you want to use a USB use rufus... Best of luck! :D

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-08-31 11:13:46 -0500

Seen: 1,439 times

Last updated: Sep 19 '14