Samba Timeout when starting nmb

asked 2014-08-30 14:09:25 -0500

RushFan1968 gravatar image

updated 2014-11-17 08:10:22 -0500

Hello, I have been following a closed thread, ( https://ask.fedoraproject.org/en/question/40353/how-to-enable-samba-share-for-a-specific-directory-fedora-20/40354? ), to install and run samba. All bodes well until I try to start the nmb service. I am getting the following: failed (Result: timeout). I have copied some of the output from the nmb start failure: create_subnets: No local IPv4 non-loopback interfaces ! So I am wondering if this problem is specific to the eth0. Here is the remainder of the error stack: Starting Samba NMB Daemon...[2014/08/31 17:44:32.076112, 0] ../source3/param/loadparm.c:3067(lp_set_enum_parm)...[2014/08/31 17:44:32.098566, 0] ../source3/nmbd/nmbd_subnetdb.c:250(create_subnets)...create_subnets: No local IPv4 non-loopback interfaces !...[2014/08/31 17:44:32.098752, 0] ../source3/nmbd/nmbd_subnetdb.c:251(create_subnets)...create_subnets: Waiting for an interface to appear ...nmb.service operation timed out. Terminating....Failed to start Samba NMB Daemon....Unit nmb.service entered failed state.

Any ideas please? Thanks.

Update: I am now able to start nmb service however, despite my best eforts cannot get Samba to allow Win users to browse via NN.Also, more importantly, I see a degrade in Win NN that is definitely caused by Samba. I lose access to machines steadliy until I have to turn off the samba and let NN refesh itself.

edit retag flag offensive close merge delete