Ask Your Question
1

Windows cannot access <linux box>

asked 2014-08-22 21:34:04 -0500

RushFan1968 gravatar image

updated 2014-08-28 10:54:56 -0500

FranciscoD_ gravatar image

Hello, I have followed setup instructions to the tee, I have Fedora 20 in my workgroup along with several windows boxes. The fedora server shows up in network neighborhood but selecting it only opens a network error 'Windows cannot access...'. I have opened the samba client and samba ports on both production and home. Kindly please suggest possible solution(s). Thanks!

edit retag flag offensive close merge delete

Comments

Hi, I tried all the steps from the above link with no luck.

RushFan1968 gravatar imageRushFan1968 ( 2014-08-23 04:45:49 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2014-08-23 05:20:49 -0500

cobra gravatar image

It's likely to be a permissions issue on the Linux machine. Samba imposes permissions first, then you run into Linux filesystem permissions too.

You either need to create accounts on the Linux machine using the Windwos usernames with the smbpasswd command, or open up your samba permissions to allow guests to read stuff.

If you need help doing this, then add your smb.conf to your question and we can take a look and make more specific suggestions (don't forget to remove any sensitive passwords, etc.)

edit flag offensive delete link more

Comments

Thank you, Cobra

RushFan1968 gravatar imageRushFan1968 ( 2014-09-03 03:27:26 -0500 )edit

Aside from the permissions issue there is an even more alarming problem. I can get the linux box to show up in NN but almost immediately it starts to degrade the windows network by that I mean refreshing the Network links shows fewer and fewer machines until there is only a couple available from any machine. If I turn off the linux box I can get the Network Neighborhood to gradually pick up all the boxes. I am completely stupified.

RushFan1968 gravatar imageRushFan1968 ( 2014-11-29 01:28:08 -0500 )edit

This is a bit of a guess, but it looks like your smb.conf might be enabling windows networking features of samba that aren't needed, and are trampling over other service providers on the network. Take a look in your /etc/samba/smb.conf file (it's a text configuration) and turn off things like local master=no, preferred master=no, wins proxy=no and dns proxy=no.

If you turn such networking elements of your samba configuration off you might be able to work out which is causing the pain. It might be a combination of them so watch out. And there are other values, see man smb.conf.

cobra gravatar imagecobra ( 2014-11-29 05:31:26 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2014-08-22 21:34:04 -0500

Seen: 275 times

Last updated: Aug 22 '14