Ask Your Question
1

how to fast boot up fedora 20 [closed]

asked 2014-08-16 19:50:04 -0500

Subin MT gravatar image

updated 2014-08-16 21:31:42 -0500

NickTux gravatar image

Duplicate of: Improving boot time/disabling useless services.

This question has been asked before and already has an answer.


how to fast boot up fedora 20.?after installation of some software it will take much time which more than windows..

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by NickTux
close date 2014-08-16 21:31:51.511337

1 Answer

Sort by ยป oldest newest most voted
2

answered 2014-08-16 20:40:47 -0500

abadrinath gravatar image

updated 2014-08-16 20:46:09 -0500

Look at my boot time before using systemd-analyze:

3.212s (kernel) + 2.793s (initrd) + 27.860s (userspace)
First of all, disable some services that are not really needed. I recommend/don't recommend disabling:
cups.path                                   Not needed unless you need printing
anaconda-direct.service                     Not needed, disable it
arp-ethers.service                          Not needed
auditd.service                              Don't disable this one
autovt@.service                             Disable it
avahi-daemon.service                        Not needed
blk-availability.service                    Not needed
bluetooth.service                           Disable if you don't need bluetooth
canberra-system-bootup.service              disabled
canberra-system-shutdown-reboot.service     disabled
canberra-system-shutdown.service            disabled
capi.service                                disabled
chrony-wait.service                         disabled
chronyd.service                             disabled
console-getty.service                       disabled
console-shell.service                       disabled
cpupower.service                            disabled
cups-browsed.service                        disabled
cups.service                                disabled
debug-shell.service                         disabled
dm-event.service                            disabled
dmraid-activation.service                   disabled
dnsmasq.service                             disabled
ebtables.service                            disabled
fcoe.service                                disabled
fedora-domainname.service                   disabled
firewalld.service                           I wouldn't recommend disabling unless you have iptables set up
initial-setup-graphical.service             disabled
initial-setup-text.service                  disabled
ipsec.service                               disabled
irda.service                                disabled
irqbalance.service                          disabled
iscsi.service                               disabled
iscsid.service                              disabled
iscsiuio.service                            disabled
isdn.service                                disabled
lldpad.service                              disabled
lvm2-lvmetad.service                        disabled
lvm2-monitor.service                        disabled
mariadb.service                             disabled
mdmonitor.service                           disabled
minetest@.service                           disabled
ModemManager.service                        disabled
mysqld.service                              disabled
NetworkManager-wait-online.service          disabled
nfs-blkmap.service                          disabled
nfs-idmap.service                           disabled
nfs-lock.service                            disabled
nfs-mountd.service                          disabled
nfs-rquotad.service                         disabled
nfs-secure-server.service                   disabled
nfs-secure.service                          disabled
nfs-server.service                          disabled
nfs.service                                 disabled
nfslock.service                             disabled
openvpn@.service                            disabled
plymouth-halt.service                       disabled
plymouth-kexec.service                      disabled
plymouth-poweroff.service                   disabled
plymouth-read-write.service                 disabled
plymouth-reboot.service                     disabled
pppoe-server.service                        disabled
psacct.service                              disabled
rdisc.service                               disabled
rpcbind.service                             disabled
rpcgssd.service                             disabled
rpcidmapd.service                           disabled
rpcsvcgssd.service                          disabled
rsyncd.service                              disabled
rsyslog.service                             disabled
serial-getty@.service                       disabled
smartd.service                              disabled
speech-dispatcherd.service                  disabled
spice-vdagentd.service                      disabled
sshd.service                                disabled
sssd.service                                disabled
svnserve.service                            disabled
systemd-nspawn@.service                     disabled
tcsd.service                                disabled
tlp.service                                 disabled
tuned.service                               disabled
upower.service                              disabled
wpa_supplicant.service                      disabled
xl2tpd.service                              disabled
zvbid.service                               disabled
avahi-daemon.socket                         disabled
cups.socket                                 disabled
lvm2-lvmetad.socket                         disabled
rpcbind.socket                              disabled
rsyncd.socket                               disabled
sshd.socket                                 disabled
ctrl-alt-del.target                         disabled
halt.target                                 disabled
kexec.target                                disabled
nfs.target                                  disabled
poweroff.target                             disabled
reboot.target                               disabled
rescue.target                               disabled
runlevel0.target                            disabled
runlevel1.target                            disabled
runlevel6.target                            disabled
yum-makecache.timer                         disabled

After disabling services, my boot time is:

3.912s (kernel) + 2.493s (initrd) + 14.388s (userspace)

Next, remove the journal using:

$ mv /var/log/journal /var/log/journal.org

The boot time is now:

2.928s (kernel) + 3.493s (initrd) + 10.860s (userspace)

Last, add these things to kernel line:

 root=/dev/sda10 rootfstype=ext4 rw vconsole.font=latarcyrheb-sun16 rhgb quiet libahci.ignore_sss=1 raid=noautodetect

Then, edit /etc/fstab and comment the line for the root partition.

Reboot twice! Now, you have a super fast Fedora.

My boot time now is:

3.158s (kernel) + 2.955s (initrd) + 9.694s (userspace)

For addition tweaks, visit

https://www.harald-hoyer.de/2013/11/13/fedora-boot-optimization/

https://wiki.archlinux.org/index.php/Improve_boot_performance

https://bbs.archlinux.org/viewtopic.php?id=135643 ... (more)

edit flag offensive delete link more

Comments

Please, search before you answer :)

NickTux gravatar imageNickTux ( 2014-08-16 21:32:25 -0500 )edit

ok ;) will do in future.

abadrinath gravatar imageabadrinath ( 2014-08-16 21:35:34 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2014-08-16 19:50:04 -0500

Seen: 4,008 times

Last updated: Aug 16 '14