Ask Your Question
1

KDE System Settings don't remember connector for built-in audio

asked 2014-08-16 19:25:29 -0500

Christian gravatar image

updated 2014-09-29 16:10:45 -0500

mether gravatar image

Hi there,

I'm on F20, KDE 4.13.3. Every time I log in to the system, I have to remind KDE/Phonon to please use line out as the default audio destination, as opposed to headphones (which aren't connected). That is, I need to open System Settings -> Multimedia -> Audio and Video Settings -> Audio Hardware Setup -> select "Built-in Audio" sound card -> "Playback" sound device -> "Line Out" connector, and hit "Apply".

Obviously, this isn't particularly fun. Any advice? Where's the config file or sqlite DB that I can tweak so this finally sticks?

Thanks...

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2014-08-18 19:55:09 -0500

Christian gravatar image

Turns out the problem was that PulseAudio didn't pick the right port for the given sink. User "hello"'s suggestion got me on the right track. In my case, the built-in card has index 1 and lists, among others:

index: 1
    name: <alsa_card.pci-0000_00_1b.0>
    driver: <module-alsa-card.c>
    owner module: 7
    properties:
            alsa.card = "1"
            alsa.card_name = "HDA Intel"
            alsa.long_card_name = "HDA Intel at 0xfe8f4000 irq 45"
            alsa.driver_name = "snd_hda_intel"
            device.description = "Built-in Audio"
            #....
    profiles:
            input:analog-stereo: Analog Stereo Input (priority 60, available: unknown)
            output:analog-stereo: Analog Stereo Output (priority 6000, available: unknown)
            #....
    active profile: <output:analog-stereo+input:analog-stereo>
    sinks:
            alsa_output.pci-0000_00_1b.0.analog-stereo/#0: Built-in Audio Analog Stereo
    sources:
            alsa_output.pci-0000_00_1b.0.analog-stereo.monitor/#1: Monitor of Built-in Audio Analog Stereo
            alsa_input.pci-0000_00_1b.0.analog-stereo/#2: Built-in Audio Analog Stereo
    ports:
            # ...
            analog-output-lineout: Line Out (priority 9900, latency offset 0 usec, available: no)
                    properties:

            analog-output-headphones: Headphones (priority 9000, latency offset 0 usec, available: no)
                    properties:
                            device.icon_name = "audio-headphones"

So it's pretty obvious that the idea is to se the default port for the (only) sound sink. I did this by adding the following to /etc/pulse/default.pa:

set-sink-port alsa_output.pci-0000_00_1b.0.analog-stereo analog-output-lineout

I did not need to wipe any existing state in my home directory.

edit flag offensive delete link more
1

answered 2014-08-16 19:43:39 -0500

abadrinath gravatar image

updated 2014-08-19 01:12:07 -0500

If your audio output port is wrong, add this to /etc/pulse/default.pa:

set-sink-port alsa_output.pci-0000_00_1f.5.analog-stereo analog-output-mono;output-amplifier-on

Change that with your customized card name, etc.. For more info, check

http://superuser.com/questions/137805/set-default-system-audio-output-port-for-all-accounts

and

http://ubuntuforums.org/showthread.php?t=1475799

edit flag offensive delete link more

Comments

Thanks for the input! It got me on the right track. I think you're describing the way to specify a sink, whereas my problem was that I needed to specify the port for a sink. That's probably also why the kmix suggestion doesn't apply -- the level of change I need to make doesn't show up in the mixer settings.

Christian gravatar imageChristian ( 2014-08-18 19:56:39 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2014-08-16 19:25:29 -0500

Seen: 1,462 times

Last updated: Aug 19 '14