'Unable to enumerate USB device on port' error while connecting ZTE CDMA modem in F20 [closed]

asked 2014-08-15 11:51:16 -0500

vineeth gravatar image

updated 2014-09-12 19:03:24 -0500

mether gravatar image

Hi all, I recently installed Fedora 20 in my system. After the installation, I connected my ZTE CDMA modem to the USB port and tried to connect to the internet via KPPP. But it could not find modem in any of the usual /dev links.

On running lsusb command, I could see that the device has indeed been recognized correctly as it was listing an 'ZTE WCDMA Technologies MSM' entry

[root@localhost ilyushin]# lsusb
Bus 002 Device 005: ID 0a5c:21b4 Broadcom Corp. BCM2070 Bluetooth 2.1 + EDR
Bus 002 Device 004: ID 0461:4d0f Primax Electronics, Ltd HP Optical Mouse
Bus 002 Device 010: ID 19d2:fffe ZTE WCDMA Technologies MSM
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 002: ID 174c:5106 ASMedia Technology Inc. Transcend StoreJet 25M3
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 003: ID 0fce:715a Sony Ericsson Mobile Communications AB Xperia Pro [Tethering]
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 064e:e258 Suyin Corp. HP TrueVision HD Integrated Webcam
Bus 001 Device 003: ID 138a:0018 Validity Sensors, Inc. Fingerprint scanner
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

However dmesg command was showing an "unable to enumerate USB device on port" error while connecting the device

[root@localhost ilyushin]# dmesg
[ 1463.749158] usb 2-1.1: new full-speed USB device number 6 using ehci-pci
[ 1463.823105] usb 2-1.1: device descriptor read/64, error -32
[ 1463.998039] usb 2-1.1: device descriptor read/64, error -32
[ 1464.171748] usb 2-1.1: new full-speed USB device number 7 using ehci-pci
[ 1464.245912] usb 2-1.1: device descriptor read/64, error -32
[ 1464.420821] usb 2-1.1: device descriptor read/64, error -32
[ 1464.594719] usb 2-1.1: new full-speed USB device number 8 using ehci-pci
[ 1464.996374] usb 2-1.1: device not accepting address 8, error -32
[ 1465.069471] usb 2-1.1: new full-speed USB device number 9 using ehci-pci
[ 1465.471022] usb 2-1.1: device not accepting address 9, error -32
[ 1465.471209] hub 2-1:1.0: unable to enumerate USB device on port 1
[ 1469.378107] usb 2-1.1: new full-speed USB device number 10 using ehci-pci
[ 1469.464808] usb 2-1.1: New USB device found, idVendor=19d2, idProduct=fffe
[ 1469.464818] usb 2-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 1469.464824] usb 2-1.1: Product: ZTE CDMA Tech
[ 1469.464828] usb 2-1.1: Manufacturer: ZTE, Incorporated

I got similar errors on both USB 2.0 and USB 3.0 ports in my system.

I tried upgrading to the latest kernel version through yum to check whether it would solve the issue, but it hasn't. The last Fedora ... (more)

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by florian
close date 2016-04-04 13:31:47.646039

Comments

Isn't there any messages related to the device after the line you wrote?

hedayat gravatar imagehedayat ( 2014-08-15 13:57:25 -0500 )edit
florian gravatar imageflorian ( 2016-04-04 13:31:57 -0500 )edit