Ask Your Question
2

How to completely remove Fedora from a Windows 8.1 PC (or fix it)

asked 2014-08-14 14:02:32 -0500

rjusa gravatar image

updated 2014-08-22 10:03:14 -0500

Several months ago, I asked a question here about "How to dual boot Windows 8.1 and Fedora 20", which I still have not been able to solve.

I had to disable Secure Boot in order to be able to run the Fedora installation CD (which I understand shouldn't be necessary, but for my PC it was). Now that I have Fedora installed, I can't even run Windows 8.1 if I enable Secure Boot again. You can read more details in my previous question ( https://ask.fedoraproject.org/en/question/46803/how-to-dual-boot-windows-81-and-fedora-20/ ). I tried disabling fast startup in Windows 8.1, but it didn't make any difference.

For some odd reason, I have not been able to boot from the live CD that I burned to try to run fsck. I tried burning it on a second CD, but it still doesn't work, even though it boots OK on an old Windows XP computer. I tried reinstalling Fedora in the past, but that didn't fix the problems I've been having either.

I've gotten so frustrated with UEFI (which seems to me like an Undesirable Extremely Fierce Intruder ;o) that I finally decided to try to remove Fedora from my PC and only run it from a USB flash drive or on my old WinXP computer where I have dual boot successfully set up.

I know how to delete the Fedora partition(s), but I want to reset my EFI partition so that there are no traces of Fedora (or GRUB) left on it to cause any more problems. I've done research on how to do this, but I've seen various different suggestions and wanted to make sure that I do the right thing.

How should I go about this? (Please don't suggest any commands to reset the BIOS. They won't do any good, because my PC uses UEFI and doesn't have a BIOS. Also, if anyone has any suggestions not yet mentioned for getting dual boot to work, I'll gladly try them.) I don't want to have to reset Windows 8.1 if I don't need to, and I already tried reinstalling it, but I still got a "Secure Boot Violation" error when I turned Secure Boot on.

-- Timothy

EDIT: I have added a link to a screenshot of GParted which I ran from the Fedora live CD on my computer: ( https://drive.google.com/file/d/0BxjTpNHa9FIZR2dmVkZpYjZ0WGc/edit?usp=sharing ). (I would have placed the image directly in my post, but I don't have enough karma.)

I have no idea why there are eight(!) partitions shown in GParted, since my computer was new when I got it and I never specifically created any. I thought the Fedora installer created only two partitions, and that my Windows 8.1 PC came with only three or four (including an HP recovery partition).

edit retag flag offensive close merge delete

Comments

How do you boot Windows when secure boot is on? You should NOT try to boot windows from GRUB. Instead, choose Windows directly from UEFI boot menu. Does it work? Booting windows from Grub would not work with Secure boot.

About removing Fedora, you should first be able to boot windows normally without any intervention of Grub, then you can simply remove all Fedoar partitions and Grub related files from EFI partition.

hedayat gravatar imagehedayat ( 2014-08-15 03:17:46 -0500 )edit

Hi Timothy, sorry I couldn't assist you earlier. Try my answer below. Hope I help.

abadrinath gravatar imageabadrinath ( 2014-08-15 05:11:09 -0500 )edit

@hedayat: I can't boot Windows when secure boot is on. That's one of the problems I'm having. Do you mean that I need to press the Esc key every time I start my computer to bring up the Boot Device menu and select Windows from it? @hello: Thank you for trying to help. See my comment on your answer below.

rjusa gravatar imagerjusa ( 2014-08-15 16:45:40 -0500 )edit

First of all, I'd like to know if selecting Windows using the "Boot Device menu" does work when secure boot is on?

hedayat gravatar imagehedayat ( 2014-08-16 01:51:55 -0500 )edit

Thanks for the suggestion. If I turn secure boot on, I can indeed then start Windows from the UEFI boot device menu (not GRUB), which I hadn't realized before. But then I can't run Fedora because UEFI complains about a "Secure Boot Violation". I could probably fix that if I compile my own secure boot keys, but I'm more concerned right now about being able to get Windows 8.1 and Fedora to dual boot properly regardless of whether or not secure boot is turned on (see my comments on hello's answer below).

rjusa gravatar imagerjusa ( 2014-08-20 14:28:46 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
5

answered 2014-08-15 05:09:58 -0500

abadrinath gravatar image

updated 2014-11-13 19:29:32 -0500

Removing Windows 8 and make Fedora only OS

First of all, I am sorry I couldn't solve your problem earlier. Now, though, I think that I can fix your problem without much trouble/nuisance. Sorry for that.

Step 1. Boot into the BIOS Settings. The key for entering the BIOS settings is often Esc, F2, F12, F10, Enter. This key for entering the BIOS depends on the vendor and model, so please consult your manual or Google if you cannot figure out this key. Once you are in the Settings, head over to the Section called Boot or Security. The screen should look like this:

UEFI

Step 2. Set Legacy support as second priority, and if possible, even disable it. Use the arrow keys and Enter keys to navigate through the menus. With the UEFI turned on and legacy support off, now we have to disable secure boot. Navigate and disable the Secure boot as in the picture above.

Step 3. With the secure boot off and UEFI still on, boot into a Fedora LiveCD or a LiveUSB using the BIOS boot menu. Again, this can be accessed using F8, F12 or options in the BIOS Settings. Another option is to change the Boot order (in the picture, it is 1st Boot Device, 2nd Boot Device, etc.).

Step 4. In theory, you should be able to boot perfectly with secure boot disabled. If this doesn't work, please don't hesitate to leave a comment. The possible problems are

  • Secure Boot violation - FIXED
  • Automatic going to Windows 8 - FIXED

Step 5. Once in the LiveCD, you are free to perform any tasks. This is one command I would certainly recommend:

# yum install gparted
then,
# gparted

From there, you can format your partitions, remove them, create them as you wish. If you would like a command line tool, try parted (installed by default). Remove your Windows partition (both booting partition and Windows C: partition as they are unneeded for now). If you want to keep these partitions, use clonezilla to clone your disk for a backup in case of an emergency.

Step 6. After removing Windows, click on Install to Hard Disk. Follow the trivial instructions from Anaconda. You will need to give a time zone, install media, choose packages, begin installation, set password for root, and create a new user. Then, reboot.

Step 7 (optional). Boot to the BIOS Settings again, and now, turn Secure Boot back on. Secure Boot will now be enabled. In case there is a violation message, turn it off, and boot into Fedora. From there, compile your own secure boot keys using these tutorials/wikis:

http://fedoraproject.org/wiki/Secureboot

http://fedoraproject.org/wiki/Features/SecureBoot

Dual booting Windows 8 and Fedora 20

No need for me to repeat anything, just omit the step where you remove the partitions through gparted. If you have two /boot/efi partitions going, GRUB2 won't recognize the Windows8 EFI partition. To fix that, add this

menuentry 'Microsoft Windows ...
(more)
edit flag offensive delete link more

Comments

Thanks, I appreciate your help. From your answer, it looks like I'll need to compile my own secure boot keys if I want to be able to turn secure boot on. I may not bother with that though, since that's not my main problem (although it may be part of it), which is why I'm leaving this comment. You said that if secure boot is disabled, "automatic going to Windows 8" should be fixed. My main problem is that that doesn't fix it for me. I already have secure boot disabled, because as I mentioned, I can't boot Windows if it is turned on, but still no GRUB menu appears and Windows immediately starts. Note: I admit that maybe I was too hasty to want to remove Fedora, but I definitely know I want to keep Windows 8.

rjusa gravatar imagerjusa ( 2014-08-15 17:23:43 -0500 )edit

I finally figured out that the reason I couldn't boot the Fedora live CD was because I was using the 32-bit version, and only the 64-bit version supports UEFI. I downloaded the 64-bit XFCE ISO and burned it to a CD, and it booted. I tried running fsck (with su) on my main Fedora partition (/dev/sda8), but it gave an error because the filesystem was locked (I don't know why). I added a link to a screenshot of GParted in my original post, which will hopefully shed some light on my problem. Any suggestions?

rjusa gravatar imagerjusa ( 2014-08-20 14:31:58 -0500 )edit

I have just tried the dual boot option with Windows 7 and Fedora 20. Works fine. Since Windows 7 does not support it, Secure Boot is disabled. Let's say I follow this guide using Windows 8.1 and Fedora 20. If I enable Secure Boot after adding the Windows 8.1 GRUB entry, both OSs should boot properly from GRUB, right?

cgonz31 gravatar imagecgonz31 ( 2014-10-25 16:31:28 -0500 )edit

Yup, theoretically. Although, I have to warn you, sometimes it doesn't work.

abadrinath gravatar imageabadrinath ( 2014-10-27 00:41:39 -0500 )edit

OK. Thanks anyway. Theoretical question only.

As a matter of fact, your answer has been THE most accurate I have found online regarding UEFI dual booting with Windows. I followed advice from many other guides on setting up the dual boot and kept getting stuck on the GRUB editing. Then I found your answer and fixed it in 5 minutes. Thanks.

cgonz31 gravatar imagecgonz31 ( 2014-10-28 00:40:51 -0500 )edit

Question Tools

3 followers

Stats

Asked: 2014-08-14 14:02:32 -0500

Seen: 13,461 times

Last updated: Nov 13 '14