Ask Your Question
1

High CPU, Suspend not working, short battery life

asked 2014-08-12 21:25:01 -0500

Arhum gravatar image

Hello, I thank those in advance for replying. I'm running Fedora 20 on a dual boot with windows 8.1. I have an i7 processor ivybridge with INtel integrated graphics as well as a Nidia geforce gt graphics card. Fedora 20 has been running with very high and hot CPU usage and hence the battery life is half of what it is on windows. I have it fully updated. The suspend also does not work. The screen will go off when i shut the lid, but the fans and cpu are still running.

edit retag flag offensive close merge delete

Comments

1

It is likely that your NVidia card is always on, and consuming battery. Have you tried Bumblebee to at least turn it off? (I'm not sure but nowadays it might be possible to turn it off without using Bumblebee.)

hedayat gravatar imagehedayat ( 2014-08-13 01:15:33 -0500 )edit
2

It could also be that you've a process running that is being overly gregarious with your CPU. As @hedayat says, the gpu could be causing the suspend failure and using up extra battery, but it's unlikely to be using lots of CPU. Use the top command in a terminal (or any process monitor) to find out what's eating all your CPU cycles.

cobra gravatar imagecobra ( 2014-08-13 05:24:56 -0500 )edit

Thank you for your responses. After trying to install bumblee im displayed with the error, "[ 272.917570] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) Failed to load module "mouse" (module does not exist, 0) [ 272.917651] [ERROR]Aborting because fallback start is disabled.". This seems to imply my Nvidia gpu isnt running perhaps? After checking out the top command, i've found that its the gnome shell thats eating crazy cpu. System moniotr is showing 8 cpus all fluctuating pretty high with the 8th moving from 50-80% I also get "some devices failed to suspend or early wake detected.

Arhum gravatar imageArhum ( 2014-08-14 00:30:59 -0500 )edit
1

As @cobra said, your high CPU usage is not related to the problem I guessed (actually I overlooked that you have high CPU usage, so this is the primary problem that you should tackle). Gnome shell might generate error logs, you can check journalctl -lf output to see if there are (lots of) error logs by gnome shell. Also, please give us the output of glxinfo | grep render command.

hedayat gravatar imagehedayat ( 2014-08-14 04:43:49 -0500 )edit

This error is repeated when typing journal command "Aug 14 08:42:21 arhumfedora NetworkManager[598]: <warn> nl_recvmsgs() error: (-33) Dump inconsistency detected, interrupted". Also the output from the glxinfo command is "direct rendering: Yes GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer, GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer, OpenGL renderer string: Mesa DRI Intel(R) Ivybridge Mobile GL_MESA_texture_signed_rgba, GL_NV_conditional_render, GL_NV_depth_clamp, GL_NV_conditional_render, GL_NV_depth_clamp, GL_NV_light_max_exponent,"</warn>

Arhum gravatar imageArhum ( 2014-08-14 07:45:28 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-09-25 07:21:27 -0500

bull500 gravatar image

Hey, check if your system is a hybrid(optimus) graphics system

in terminal type: lspci -v | grep VGA

If you get a 2 line output like below, then you need bumblebee for your Nvidia 00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller]) 01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 525M] (rev ff) (prog-if ff)

Follow the steps here - http://fedoraproject.org/wiki/Bumblebee

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-08-12 21:25:01 -0500

Seen: 681 times

Last updated: Sep 25 '14