Ask Your Question

Online Accounts - Gmail Password Unexpectedly Fails [closed]

asked 2014-08-01 08:25:10 -0500

torvum gravatar image

Ever since the most recent update (or perhaps the one before that), I've had trouble with my Fedora 20 "Online Accounts" feature, specifically as applied to my Gmail account.

So, here's the problem I'm having:

All of a sudden, I'm now periodically prompted by Fedora to enter my Gmail account password. When I do so, it tells me my password was typed incorrectly. Now, I'm 100% positive I'm typing it right. No problem, I'll just erase my Gmail account in the "Online Accounts" section of Settings, and start from scratch; surely that will fix my problem.

I erase my Gmail account, and begin to re-add the same account. The gmail log-in screen pops up, I type in my email and password, and it transfers me to the confirmation page—the one that asks you about whether you're ok with Fedora having access to all these different bits of info—at which point I confirm and yay, my account it setup and this time it's going to work for sure because I just logged into my gmail account using the "Online Accounts" feature so it just must work now, right? Nope.

Five seconds later the same password prompt pops up asking me to supply my Gmail password, after which it invariably tells me I've typed it wrong.

* Confused and frustrated *

Any help would be much appreciated!

N.B.: I'm not sure if this is important, but my password does include special characters, i.e. those that are found above the number keys.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by florian
close date 2016-04-13 22:11:00.683884


An idea: try switching imap to pop or pop to imap servers!

abadrinath gravatar imageabadrinath ( 2014-08-01 20:55:41 -0500 )edit

I'm having the exact problem, Fedora 20 64bit, latest updates

ruturajv gravatar imageruturajv ( 2014-08-01 22:24:36 -0500 )edit

Are you using Two-Factor Authentication?

QuLogic gravatar imageQuLogic ( 2014-08-02 00:22:05 -0500 )edit

strangely its started working automatically !!! WTF ?!

ruturajv gravatar imageruturajv ( 2014-08-02 06:45:22 -0500 )edit

Well, I think the problem just comes back. I've pressed cancel more than a few times. More importantly, however, I don't see my google calendar events which leads me to believe it's not actually connecting to the service.

As for switching imap to pop or vice versa, I'm really not sure how to do that. I don't see any options in the "Online Accounts" section.

torvum gravatar imagetorvum ( 2014-08-02 17:46:59 -0500 )edit

13 Answers

Sort by » oldest newest most voted

answered 2014-08-06 08:58:53 -0500

Brent gravatar image

This error started after the update I ran on July 30th. Below is the packages that where updated:

Jul 30 08:49:54 Updated: systemd-libs-208-21.fc20.x86_64

Jul 30 08:50:44 Updated: systemd-208-21.fc20.x86_64

Jul 30 08:50:46 Updated: libteam-1.11-1.fc20.x86_64

Jul 30 08:50:47 Updated: teamd-1.11-1.fc20.x86_64

Jul 30 08:50:49 Updated: libgudev1-208-21.fc20.x86_64

Jul 30 08:50:53 Updated: systemd-python-208-21.fc20.x86_64

Jul 30 08:50:55 Updated: systemd-devel-208-21.fc20.x86_64

Jul 30 08:50:56 Updated: systemd-python3-208-21.fc20.x86_64

Jul 30 08:50:57 Updated: supermin-5.1.9-1.fc20.x86_64

Jul 30 08:51:02 Updated: libreoffice-gallery-vrt-network-equipment-1.1.1-1.fc20.x86_64

Jul 30 08:51:03 Updated: libndp-1.3-1.fc20.x86_64

Jul 30 08:51:56 Updated: mate-themes-extras-1.8.2-1.fc20.noarch

Jul 30 08:52:02 Updated: steam-

Jul 30 08:52:04 Updated: systemd-libs-208-21.fc20.i686

Jul 30 08:52:05 Updated: libgudev1-208-21.fc20.i686

Not sure which one caused it. I think it's something to do with systemd. Thanks

edit flag offensive delete link more


To add, I believe this is now a problem with evolution. If you open evolution, you will see that you can access mail and contacts without a problem. You then select calendar, you will be asked for a password until you hit cancel.

Brent gravatar imageBrent ( 2014-08-06 13:27:16 -0500 )edit

None of these packages are related, so I bet Google changed something on their end.

catanzaro gravatar imagecatanzaro ( 2014-08-12 19:37:51 -0500 )edit

There's an option to "encrypt your data" within google-chrome with a separate password; I wonder if that has anything to do with this. I'm surprised at the comment above that says even the user's Windows client isn't able to authenticate correctly. So, it makes sense to assume that it must be on Google's end somewhere.

ILMostro gravatar imageILMostro ( 2014-08-26 05:28:07 -0500 )edit

I updated mye Feora 20 some days ago, and then the keyring problem dissapeared, and I saw the google calendar with my appointmens in the taskbar and in evolution, but the kernel modules missed for the wlandriver, so it wasn't any internet connection when this happend. When the right kmod for wl were installed. The problem was back. I'm in no position to judgde whether this kmod pack has something to do with this, but I suppose the people working with this problem read this post?

dagr gravatar imagedagr ( 2014-08-31 14:42:54 -0500 )edit

answered 2014-12-06 08:19:56 -0500

I was having this problem. The solution for me was as follows: 1) Log in to Gmail using the web Interface 2) Click my profile pic 3) Click Account 4) Click the 'Security' tab 5) In the 'Account permissions' box, next to 'Access for less secure apps,' click 'Settings.' 6) For the 'Access for less secure apps' setting, click the 'Enable' radio button. 7) Log-in w/ Evolution and/or Thunderbird. 8) BOOM. Done!

edit flag offensive delete link more

answered 2014-08-27 13:13:12 -0500

jflory7 gravatar image

Same issue happens with me. I will upvote and comment on the bug report as well to help bring some attention to it!

edit flag offensive delete link more

Question Tools



Asked: 2014-08-01 08:25:10 -0500

Seen: 17,814 times

Last updated: Mar 08 '15