Ask Your Question
3

How to disable touch screen?

asked 2014-07-19 10:40:55 -0500

dcpust gravatar image

updated 2014-09-30 06:56:02 -0500

mether gravatar image

Hi folks,

I'm running F20 and I want to disable the superfluous touchscreen of my laptop - the touch pad is enough.

I could identify the input device using xinput list

[root@localhost ~]# xinput list

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Atmel Atmel maXTouch Digitizer            id=10   [slave  pointer  (2)]
⎜   ↳ ETPS/2 Elantech Touchpad                  id=13   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Video Bus                                 id=6    [slave  keyboard (3)]
    ↳ Power Button                              id=7    [slave  keyboard (3)]
    ↳ Sleep Button                              id=8    [slave  keyboard (3)]
    ↳ USB2.0 UVC HD Webcam                      id=9    [slave  keyboard (3)]
    ↳ Asus WMI hotkeys                          id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]

As you can see, the "Atmel Atmel maXTouch Digitizer" is the one which I want to turn off. I managed to do that by using the command:xinput disable <device id> But I have had to enter this command after every reboot. So a permanent solution has been necessary. Thanks to Hello I got the advice to "add a shell script" to the "/etc/init.d (directory)" resp. /etc/rc.d/init.d/. No sooner said than done. I created with gedit a text file containing:

#!/bin/bash
xinput disable 10

and moved it to the designated folder.

But after restarting there was no difference. I still have to disable the touch screen manually. I assume that the script isn't executed during the boot.

Any suggestions what to do next? Please help!

edit retag flag offensive close merge delete

Comments

Check in System Settings.

abadrinath gravatar imageabadrinath ( 2014-07-19 21:11:30 -0500 )edit

Hello hello, could you give further advice? In the settings, there is no option for the touch screen, unfortunately. Only for the touch pad resp. the mouse.

dcpust gravatar imagedcpust ( 2014-07-20 02:23:27 -0500 )edit

Why disable it? Does it cause any problems? You could break the system for something useless. I would love to have Fedora installed on a netbook with a touchscreen or a tablet.

Ervin gravatar imageErvin ( 2014-07-20 12:00:58 -0500 )edit
1

That's what I thought when I bought the netbook, but in the end I turned out useless. The touch pad is more precise and easier to use on a laptop. First, it was a funny gimmick, but in the end I even omitted using this shenanigan in order to to keep the screen clean of fingerprints. And it didn't cause any problems until I cracked the digitizer and replaced it by a new one. Now it causes problems due to "craftsmanship". But that's no problem as I doesn't use it anyway. In conclusion, the extra price for a touch screen on a laptop is not worth it.

dcpust gravatar imagedcpust ( 2014-07-20 12:28:33 -0500 )edit

@dcpust - thanks for warning me ;)

abadrinath gravatar imageabadrinath ( 2014-07-21 01:10:44 -0500 )edit

2 Answers

Sort by » oldest newest most voted
2

answered 2014-07-21 04:10:14 -0500

Ahmad Samir gravatar image

updated 2014-07-21 07:47:35 -0500

To make the X server ignore that device, create a .conf file under /etc/X11/xorg.conf.d/, e.g. disable-touchscreen.conf and put this in it:

Section "InputClass"
    Identifier    "Atmel Atmel maXTouch Digitizer"
    MatchIsTouchscreen   "true"
    Option    "Ignore"   "true"
EndSection

EDIT: you need to restart the X server for that config file to get considered by the X server.

edit flag offensive delete link more

Comments

@Ahmad Samir - have you tested this? should I mark as correct answer? It seems that my answer works.

abadrinath gravatar imageabadrinath ( 2014-07-22 01:26:20 -0500 )edit

Thanks alot. This did really work and was easy to accomplish. Just a small appendix so people don't have to look any further. To restart X server using commands in the terminal: telinit 3 logon and then telinit 5

dcpust gravatar imagedcpust ( 2014-07-22 12:34:07 -0500 )edit

Just logging out of whatever DE you're using restarts the X server.

In the systemd era you can also restart the X server from a virtual terminal using systemctl, restart the display-manager.service:

systemctl restart display-manager.service
Ahmad Samir gravatar imageAhmad Samir ( 2014-07-26 05:07:43 -0500 )edit
5

answered 2014-07-20 04:34:48 -0500

abadrinath gravatar image

updated 2014-07-22 03:41:52 -0500

Ok, rewriting. Sorry for the mess-up.

First, write a script called MY_SCRIPT.sh using echo:

 echo -e "\#\!/bin/bash\nxinput disable 'Atmel Atmel maXTouch Digitizer'" > MY_SCRIPT.sh #copy, paste, run this in the terminal

KDE: GUI

  1. Open Kickoff, and search Autostart.

  2. Click Add Script, and select the script (can be in any folder).

  3. Log out and back in.

KDE: CLI

  1. Open a terminal.

  2. Link or copy the script to ~/.kde/Autostart using ln -s MY_SCRIPT.sh ~/.kde/Autostart/. or cp MY_SCRIPT.sh ~/.kde/Autostart/.

  3. Log out and back in.

GNOME: GUI

Follow this picture/link for more info:

https://pragtob.files.wordpress.com/2012/04/startup_apps.png

http://pragtob.wordpress.com/2012/04/17/autostarting-applications-in-linux-mint-debian-edition/

If you're wondering why this is Linux Mint, don't worry, it's almost the same in Fedora 20 :).

Other desktop environments: CLI

  1. Open a terminal.

  2. Link or copy the script to ~/.kde/Autostart using ln -s MY_SCRIPT.sh ~/.config/autostart/. or cp MY_SCRIPT.sh ~/.config/autostart/.

  3. Log out and back in.

Note: this method will work for all desktop environments, including KDE and GNOME.

Why did my old method not work? I think it's because Fedora doesn't use init booting anymore :) Sorry for that :)

HTH, James

edit flag offensive delete link more

Comments

FYI, the original suggestion does not work because the init scripts do not know anything about the X server. The login screen is one user; the server you use when you login is under your user, etc., and none of them exist at the point the init scripts are run.

QuLogic gravatar imageQuLogic ( 2014-07-22 00:50:07 -0500 )edit

Also, it might be more robust to use "Atmel Atmel maXTouch Digitizer" as the ID instead of 10 in case the number changes.

QuLogic gravatar imageQuLogic ( 2014-07-22 00:52:19 -0500 )edit

@dcpust - If this worked, mark my answer as correct (click the gray tick) :). Thanks for the upvote (whoever did it).

abadrinath gravatar imageabadrinath ( 2014-07-22 01:27:23 -0500 )edit

@QuLogic -Thanks buddy, fixed.

abadrinath gravatar imageabadrinath ( 2014-07-22 03:41:20 -0500 )edit

Thanks for all your replies (@hello et al). Although your instructions were really precise and I followed them step by step, it didn't work in the end (neither with small altercations). I have no idea what the problem is. But thanks again for your effort.

dcpust gravatar imagedcpust ( 2014-07-22 12:57:27 -0500 )edit

Question Tools

2 followers

Stats

Asked: 2014-07-19 10:40:55 -0500

Seen: 12,455 times

Last updated: Jul 22 '14