Ask Your Question

Why isn't my system waking up post suspend?

asked 2014-07-14 15:15:34 -0500

samercier gravatar image

updated 2014-07-15 08:07:58 -0500

mether gravatar image

I followed the instructions here and got a dmesg.out here. My problem is I have no clue what to do with it. Any help?

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted

answered 2014-07-15 17:01:06 -0500

passthejoe gravatar image

I looked at your dmesg, specifically these two lines:

[ 0.000000] DMI: Hewlett-Packard HP Pavilion dv6 Notebook PC/358E, BIOS F.21 09/13/2011 [ 0.063367] smpboot: CPU0: AMD A6-3400M APU with Radeon(tm) HD Graphics (fam: 12, model: 01, stepping: 00)

I also have an HP laptop with an AMD APU, and I can't get suspend/resume working without two things being present:

1) You need the proprietary AMD Catalyst driver. Unfortunately RPM Fusion is no longer packaging it. You can either install from upstream, , or use the Fedora 19 packages in Fedora 20, which I'm doing now. (Here are my instructions on that: ).

Note: If you do want to use the upstream package from AMD, here are some tips on dependencies you'll need to make it work:

2) Once you have the Catalyst driver installed, then you need to add the path to your swap partition to GRUB. Here are my instructions on how to determine the path to your swap partition and how to add that swap partition to GRUB so it can work with suspend/resume: .

(I got the tip from here: )

Here are the steps for that:

In a terminal, find the path to your swap partition:

$ swapon -s

On my system, that returns the following:


To test this, I rebooted, paused GRUB and dropped this at the end of my bootline in GRUB:


If you can then suspend/resume successfully, it's time to make the change permanent.

To do this:

1) As root, edit /etc/default/grub and add your "resume" line to the end of all that stuff between the quote marks after GRUB_CMDLINE_LINUX=

(in my case it's resume=/dev/dm-1)

If you opened /etc/default/grub as root, you should be able to save it.

2) After you save /etc/default/grub, to make this change persist in GRUB, run:

# grub2-mkconfig -o /boot/grub2/grub.cfg

This is a lot of steps, which can be summed up: 1) add proprietary driver, 2) add "resume=/path/to/swap" to GRUB_CMDLINE_LINUX, 3) Regenerate GRUB configuration 4) Reboot and hopefully enjoy working suspend/resume with recent AMD APU-running systems.

edit flag offensive delete link more

answered 2014-07-15 01:16:12 -0500

happyfedorauser gravatar image

PS: This happens to me too. File a bug as NikTh says.

edit flag offensive delete link more


Hello and welcome to Ask Fedora. Please have a read at Ask Fedora Guidelines. You must remove/delete this post, at it's not an answer to the primary question, but it's like a comment instead. You can add a comment by clicking the add a comment button. Thank you.

NickTux gravatar imageNickTux ( 2014-07-15 01:28:03 -0500 )edit

Can't you remove it for him?

abadrinath gravatar imageabadrinath ( 2014-07-15 01:43:53 -0500 )edit

@hello, yes I can. But it's better for a new user to understand how we function here, rather than just have his (her) posts being removed by a mod :-)

NickTux gravatar imageNickTux ( 2014-07-15 01:53:30 -0500 )edit

answered 2014-07-14 16:24:36 -0500

NickTux gravatar image

Your next step is to read and follow the procedure at: How to file a bug report?

but also it's important to read this section: Do I need to file a bug?

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2014-07-14 15:15:34 -0500

Seen: 707 times

Last updated: Jul 15 '14