slow wireless connection (rt2800pci)

asked 2014-07-13 23:24:56 -0500

drc gravatar image

updated 2014-07-14 09:28:33 -0500

mether gravatar image

Wireless on x64 fedora 20 using the rt2800pci driver is ..hacky/slow/kinda bad. I've seen different posts claiming it is a known bug and is fixed, yet the issue persists.

On Ubuntu (13.10 & 14.04) the connection seems better for some reason. Thoughts?

edit retag flag offensive close merge delete

Comments

What kernel you are using ? post the results of uname -r . Maybe you need to install a newer kernel, where this problem is likely being fixed.

NickTux gravatar imageNickTux ( 2014-07-14 11:28:51 -0500 )edit

There are a large number of sites offering speed tests. Get results from the same site under Fedora and Ubuntu and post them here as a comment so that we can see how much of a difference there is. And, just to make sure, if you're having trouble loading websites, are you using the same browser and version on all distros? If not, that might be what's making the differerence.

sideburns gravatar imagesideburns ( 2014-07-14 15:15:10 -0500 )edit

Kernel: 3.15.4-200.fc20.x86_64 FireFox: Mozilla Firefox 30.0speedtest.net download: 30mbps

drc gravatar imagedrc ( 2014-07-15 01:07:57 -0500 )edit

Try to unload the module and then load it with nohwcrypt=Y option. As root , modprobe -rvf rt2800pci , then modprobe rt2800pci nohwcrypt=Y . Check the speed again.

NickTux gravatar imageNickTux ( 2014-07-15 01:13:47 -0500 )edit

Speed is down to 15mbps.

drc gravatar imagedrc ( 2014-07-15 09:11:33 -0500 )edit

Nah, I cannot suggest something else. You can report a bug if you want, but first you have to test the latest kernel (rawhide repo) and see if the bug exists there.

NickTux gravatar imageNickTux ( 2014-07-15 11:08:09 -0500 )edit

Since the Kernel upload, I haven't had the same issues. So being at 3.15 solved the problem. I'll re-post/update if anything changes.

drc gravatar imagedrc ( 2014-07-17 09:43:56 -0500 )edit