Ask Your Question
1

Does firewalld block outgoing and incoming traffic?

asked 2014-07-09 20:03:56 -0500

jjc gravatar image

updated 2014-07-11 00:12:28 -0500

I am trying to use Firefox to access PLESK on a remote box. I have Fedora 20. I use www.example.com:8880/login and get "Unable to connect" from Firefox. I assume it is the firewall. The remote box administrator assures me that it is on my end.

Do you think that it is the firewall or is it something else?

edit retag flag offensive close merge delete

Comments

Two things: first, please don't post the same question twice. Everything here is moderated, meaning that your question won't appear until approved, and whoever moderates it will simply remove the duplicates. Second, if that's the correct url, I get the same results. If it isn't, please post the url you're trying to get to as a comment so that others can try to reach it.

sideburns gravatar imagesideburns ( 2014-07-09 21:38:08 -0500 )edit

sudo iptables -L -n?

abadrinath gravatar imageabadrinath ( 2014-07-09 21:47:57 -0500 )edit

My next step in this case would be something like nmap remote_host_ip -p 8000-9000, preferably from different machines on different networks.

randomuser gravatar imagerandomuser ( 2014-07-10 11:38:10 -0500 )edit

Thank you for the answers. The nmap was very helpful.

jjc gravatar imagejjc ( 2014-07-10 13:26:07 -0500 )edit

I'd try telnet www.URL.com 8880 to see if it can successfully connect. However, as mentioned in some comments, Fedora firewall does not block any outgoing connection by default. What is the route between your system and URL.com? There may be some firewall between your connection which doesn't permit that connection.

hedayat gravatar imagehedayat ( 2014-07-10 15:01:38 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-07-10 11:01:12 -0500

NickTux gravatar image

updated 2014-07-10 17:15:57 -0500

FirewallD is blocking (almost) everything inbound, by default. It's pre-configured as if you are using your PC at a public place (Internet cafe, public hot-spot..etc).

Outbound connections will work if you initiate them, but any unsolicited connections will be dropped.

If you want to allow any incoming traffic, you have to configure FirewallD and allow the approrpiate incoming and outgoing connections/ports.

Read here a relevant answer (it is about samba, but your will figure out how to configure FirewallD).

edit flag offensive delete link more

Comments

I'm quite confident that user-initiated outbound traffic isn't restricted by the default configuration. Almost everything inbound is, though.

randomuser gravatar imagerandomuser ( 2014-07-10 11:44:30 -0500 )edit

Yeah. The outgoing traffic is not blocked, but it's a good idea (imo), to give a shot in FirewallD configuration and open any relevant port for communication.

NickTux gravatar imageNickTux ( 2014-07-10 12:06:19 -0500 )edit

Question Tools

Stats

Asked: 2014-07-09 20:03:56 -0500

Seen: 3,856 times

Last updated: Jul 11 '14