Ask Your Question
0

Fedora 20/Windows 8.1 dual boot help?

asked 2014-07-09 12:58:57 -0600

stackster gravatar image

updated 2014-09-12 19:52:27 -0600

mether gravatar image

I've partitioned my hard-drive, and Fedora 20 runs perfectly. The problem is when i try to access the Windows 8.1 partition. On start-up the screen comes up where I can pick which partition to run, but if i pick "Windows Boot Manager", I get this:

error: file '/EFI/Microsoft/Boot/bootmgfw.efi' not found.
error: you need to load the kernal first.

Press any key to continue...
edit retag flag offensive close merge delete

Comments

In what order did you install the operating systems? Is the EFI partition is shared between Windows and Fedora? Also, is the start-up menu from GRUB or UEFI (BIOS)?

Cristian Ciupitu gravatar imageCristian Ciupitu ( 2014-07-09 13:11:45 -0600 )edit

Ahh, the 2 /boot/efi problem again. Go into fedora and execute parted -l|fpaste, and post the link here.

abadrinath gravatar imageabadrinath ( 2014-07-09 20:51:01 -0600 )edit

The output of lsblk might also be useful.

Cristian Ciupitu gravatar imageCristian Ciupitu ( 2014-07-10 13:18:21 -0600 )edit

@stackster - Do you still need help?

trol1ed gravatar imagetrol1ed ( 2014-07-19 00:49:43 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted
2

answered 2014-07-22 02:06:08 -0600

abadrinath gravatar image

updated 2014-07-29 12:04:33 -0600

It's been a long time since you've been online, so I assume you've fixed it. But, I'll provide my answer anyway. Here goes:

Option 1: Modify the GRUB2 configuration

  1. Execute this bit of code:

    echo "menuentry 'Windows Boot Manager ' {
    set root='hd0,gpt$(sudo parted -l|grep fat32|grep boot|grep "EFI system partition"|awk '{print $1}')'
    chainloader /EFI/Microsoft/Boot/bootmgfw.efi
    boot
    }"
    

    The output should be close to:

    menuentry 'Windows Boot Manager ' {
    set root='hd0,gpt2'
    chainloader /EFI/Microsoft/Boot/bootmgfw.efi
    boot
    }
    
  2. Copy this output using Ctrl+Shift+C or by right clicking and clicking copy and paste, respectively. Next, execute:

    sudo vi /etc/grub.d/40_custom
    

    After that, press i, and then scroll to the bottom of the document using the arrow keys. Press Ctrl+Shift+V to paste, and then save by pressing Esc and typing :wq [ENTER].

  3. Run this command in the terminal: sudo cat /etc/grub.d/40_custom

    The output should look like

    #!/bin/sh
    exec tail -n +3 $0
    # This file provides an easy way to add custom menu entries.  Simply type the
    # menu entries you want to add after this comment.  Be careful not to change
    # the 'exec tail' line above.
    
    menuentry 'Microsoft Windows 8' {
    set root='hd0,gpt2'
    chainloader /EFI/Microsoft/Boot/bootmgfw.efi
    boot
    }
    

    Do not remove any other parts of this documents. If you accidentally mess up, do not type :wq,but instead :q! [ENTER]. Re-execute the command with the vi in it.

  4. Run grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg. Do not alter this command as it can mess up your system. Next, reboot using reboot in the command line or any other option.

  5. You should be able to access both Windows and Linux now using GRUB2.

Option 2: Using the BIOS boot menu

1. During the screen with the laptop company name (e.g. Lenovo or Acer), press F12, F1, or Esc. This key depends on model and maker of the box. On laptops, try Fn+F2, Esc, Fn+F1, etc. This is not the same as the BIOS Settings, it is the boot menu (see this for example).

  1. Press Windows 8 or Windows. Sometimes, it may be a strange string of words (name of the HDD, I think). Try each one, and check for the Windows one.

  2. You will have to do this every time you want to boot into Windows. In my opinion, this is not the best option. It takes too much effort and it is hard to do on quick BIOS computers.

Option 3: Reinstall with one /boot/efi partition

  1. Get a spin of Fedora and burn to USB, DVD, etc. You maybe want to try a netinstall.

  2. At the partitioning, select the 260 MB partition in Windows, and use that.

  3. Boot into Windows and Fedora!

Option 4: Try a Windows VM

Get a virtual machine program on Fedora. Several are available as shown here (yum search vm):

Loaded plugins: fastestmirror, langpacks, refresh-packagekit
Loading mirror speeds from ...
(more)
edit flag offensive delete link more

Comments

Sorry it took so long for me to log back on. I haven't fixed my laptop; I've had other things take priority over my laptop, and didn't have time to work on fixing it. I tried option one, but i get:

Booting a command list

error: syntax error.
error: Incorrect command
error: syntax error

Press any key to continue...

I've tried to reenter this three times, looking for errors every time and found none. I'm entering it in the screen that comes up when i highlight Windows Boot Manager at first startup, then hit "e". I'm a noob when it comes to this stuff, so sorry if thats not the right place

stackster gravatar imagestackster ( 2014-07-26 15:37:18 -0600 )edit

Option two works just fine, and it's what i have been doing in the meantime, but if possible, I would like to fix this issue since it a tad tedious to do every time I load windows.

stackster gravatar imagestackster ( 2014-07-26 15:40:09 -0600 )edit

Do a parted -l|fpaste and post link.

abadrinath gravatar imageabadrinath ( 2014-07-26 20:10:01 -0600 )edit

Oh, hit enter at that screen instead of e.

abadrinath gravatar imageabadrinath ( 2014-07-26 20:11:53 -0600 )edit

Thanks for the edit, BTW.

abadrinath gravatar imageabadrinath ( 2014-07-30 01:21:03 -0600 )edit
0

answered 2014-08-06 22:07:36 -0600

I had a similar problem with a new fedora install on a new laptop, and found I had problems booting windows 8. Checking the config I found there were 2 efi partitions. (One I had created during the install and mounted at /boot/efi, and the other the Windows efi partition at /dev/sda1)

I then could only boot windows by using the UEFI boot menu to select the windows boot manager.

The fix was really simple. I reinstalled fc20 but this time I selected the existing efi partition (/dev/sda1) to mount on /boot/efi and deleted the efi partition I had created during my previous install.

Now both OSs will boot cleanly from the fedora boot menu. The previous answer with option 1 might work, but that is a lot of work for a simple fix.

Simplest is sometimes best for chasing away these boot gremlins.

edit flag offensive delete link more

Comments

True, perfect, but reinstalling is more work IMO. =/

abadrinath gravatar imageabadrinath ( 2014-08-07 01:14:59 -0600 )edit
0

answered 2014-07-21 07:03:05 -0600

afdez gravatar image

Hi,

Probably your grub2 conf is corrupted, please take a look here:

https://fedoraproject.org/wiki/GRUB_2?rd=Grub2

edit flag offensive delete link more

Comments

No, that is unlikely. The file is not found.

abadrinath gravatar imageabadrinath ( 2014-07-22 01:35:26 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2014-07-09 12:58:57 -0600

Seen: 703 times

Last updated: Aug 06 '14