Ask Your Question
2

Fedora 20 no wifi networks

asked 2014-06-10 15:03:35 -0500

ivmartel gravatar image

updated 2014-09-12 22:59:09 -0500

mether gravatar image

Hi, I did a yum update some time ago (~2months) and then lost my wifi connection. Nothing appears in the networks list. I can connect when wired. I've been searching since but haven't resolved the problem... Here are some details:

cat /proc/version

Linux version 3.14.5-200.fc20.i686 (mockbuild@bkernel02.phx2.fedoraproject.org) (gcc version 4.8.2 20131212 (Red Hat 4.8.2-7) (GCC) ) #1 SMP Mon Jun 2 15:03:19 UTC 2014

lspci -nnk | grep -iA2 net

04:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection [8086:4222] (rev 02)
Subsystem: Intel Corporation PRO/Wireless 3945ABG Network Connection [8086:1001]
Kernel driver in use: iwl3945
Kernel modules: iwl3945, wl
05:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev 01)
Subsystem: Fujitsu Technology Solutions Device [1734:1107]
Kernel driver in use: r8169

iwconfig

p5p1      no wireless extensions.

lo        no wireless extensions.

wlp4s0    IEEE 802.11abg  ESSID:off/any  
      Mode:Managed  Access Point: Not-Associated   Tx-Power=15 dBm   
      Retry short limit:7   RTS thr:off   Fragment thr:off
      Encryption key:off
      Power Management:off

cat /var/lib/NetworkManager/NetworkManager.state

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true
WimaxEnabled=true

ip link

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default 
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: p5p1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT group default qlen 1000
link/ether 00:03:0d:73:35:7f brd ff:ff:ff:ff:ff:ff
3: wlp4s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DORMANT group default qlen 1000
link/ether 00:1b:77:b3:af:1d brd ff:ff:ff:ff:ff:ff

dmesg | egrep 'wlp4s0|iwl3945'

[   11.535550] iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, in-tree:ds
[   11.535554] iwl3945: Copyright(c) 2003-2011 Intel Corporation
[   11.535605] iwl3945 0000:04:00.0: can't disable ASPM; OS doesn't have ASPM control
[   11.589820] iwl3945 0000:04:00.0: Tunable channels: 13 802.11bg, 23 802.11a channels
[   11.589825] iwl3945 0000:04:00.0: Detected Intel Wireless WiFi Link 3945ABG
[   11.589897] iwl3945 0000:04:00.0: irq 47 for MSI/MSI-X
[   12.218171] systemd-udevd[481]: renamed network interface wlan0 to wlp4s0
[   51.040228] iwl3945 0000:04:00.0: loaded firmware version 15.32.2.9
[   51.107783] IPv6: ADDRCONF(NETDEV_UP): wlp4s0: link is not ready
[ 3389.268386] iwl3945 0000:04:00.0: no hotplug settings from platform
[ 3389.524211] IPv6: ADDRCONF(NETDEV_UP): wlp4s0: link is not ready

rfkill list

0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

The system is up to date to date from free and non-free repos. The driver too:

yum install iwl3945-firmware.noarch

Loaded plugins: langpacks, refresh-packagekit
Package iwl3945-firmware-15.32.2.9-37.fc20.noarch already installed and latest version
Nothing to do ...
(more)
edit retag flag offensive close merge delete

Comments

Why the wl driver is present ? I thought it was broadcom driver (not Intel). Also, the sudo journalctl _SYSTEMD_UNIT=NetworkManager.service > NetworkManager.txt may give us a clue.

NickTux gravatar imageNickTux ( 2014-06-11 04:28:52 -0500 )edit

wl since it is an Intel Network controller (cf lspci -nnk | grep -iA2 net above). I pasted the (shortened to only today) result of sudo journalctl there: http://ur1.ca/hi8hy Thanks for your help.

ivmartel gravatar imageivmartel ( 2014-06-11 14:44:28 -0500 )edit

Not sure if this helps, but a live usb of Ubuntu 14.04 finds networks and manages to connect.

ivmartel gravatar imageivmartel ( 2014-06-11 16:25:33 -0500 )edit

you can lspci for driver version if it is broadom then kmod-wl will solve the problem

linuxarpan gravatar imagelinuxarpan ( 2015-02-16 07:14:58 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-02-16 07:11:41 -0500

linuxarpan gravatar image

you can install kmod-wl check cybercity for installation details

edit flag offensive delete link more
0

answered 2015-02-16 11:41:21 -0500

SDas gravatar image

Search kmod-wl in fedora help you will find all the details.

edit flag offensive delete link more

Question Tools

3 followers

Stats

Asked: 2014-06-10 15:03:35 -0500

Seen: 2,601 times

Last updated: Feb 16 '15