Ask Your Question
1

fstab mount with VirtualBox shared folders

asked 2014-06-09 12:48:15 -0500

Jorge Potosme gravatar image

I have a VM with Fedora 20 x64. VBoxGuest Additions is installed, i can mount shared folders on system with mount, but i can't mount using fstab; i get "Welcome to emergency mode! After loggin in, type "journalctl -xb"..."

If i type "journalctl -xb | gerp vboxfs" i get "mount: unknow filesystem type 'vboxfs' "

This is the line in /etc/fstab, if i comment this line Fedora boot without problems "windows_c /home/wesker/windows vboxfs rw,gid=1000,uid=1000,dmode=775,fmode=664 0 0"

Are there a way to fix this problem?

edit retag flag offensive close merge delete

Comments

It looks like you additions are added after the system loads that means that they are not loaded on the kernel at boot time so when you try to load the vboxfs on fstab the system do not recognize the partition type. look on virtual box for support for that. Unless some one else knows about this issue it seems to me it is a Virtual Box issue not a Fedora Issue. Good luck

aeperezt gravatar imageaeperezt ( 2014-06-09 16:13:45 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-06-09 16:09:26 -0500

NickTux gravatar image

updated 2014-06-09 18:19:08 -0500

If i type "journalctl -xb | gerp vboxfs" i get "mount: unknow filesystem type 'vboxfs' "

This is the line in /etc/fstab, if i comment this line Fedora boot without problems "windows_c /home/wesker/windows vboxfs rw,gid=1000,uid=1000,dmode=775,fmode=664 0 0"

This is probably due to systemd and how it's behave on boot up the system. Try to use the same line on your fstab, but add the parameter comment=systemd.automount. This way the mounting procedure will be held back until you reach those mount points and this might solve your problem.

windows_c /home/wesker/windows vboxfs rw,gid=1000,uid=1000,dmode=775,fmode=664,comment=systemd.automount 0 0

If above doesn't help, see this answer on SuperUser. Maybe your are a "victim" of such bug.

Also, make sure you meet the prerequisites

  • Make sure that Guest Additions are properly installed on the guest OS.
  • Users in a guest Ubuntu must be in the group vboxsf to be able to access shares.
  • Define a directory on the host that will be used in the virtual machine using the settings dialogue of Virtual Box.
  • Do not share personal folders like /home/username or My Documents
  • Avoid special characters or empty spaces in the path to the shared folder
  • Use different names for share and mountpoint
  • Create a mountpoint on the guest OS (best in your HOME directory).

Last, but not lease, try to use the VirtualBox automount option

image description

Sources: 1, 2, 3

edit flag offensive delete link more

Comments

Thanks, extremely helpful answer.

joelthelion gravatar imagejoelthelion ( 2017-01-20 08:06:58 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2014-06-09 12:48:15 -0500

Seen: 12,069 times

Last updated: Jun 09 '14