Ask Your Question
1

Nvidia optimus Bumblebee error Fedora 20 (daemon not started)

asked 2014-06-08 18:36:54 -0500

Jesus_v2 gravatar image

Hi Guys,

This is a new install of Fedora and I just installed Bumblebee and Nvidia proprietary drivers using the instructions found here fedoraproject.org/wiki/Bumblebee#Fedora_20

When trying to run an application from the terminal using optirun command (to force using my Nvidia graphics) e.g. optirun glxspheres

I receive the following error: [20459.055485] [ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect. [20459.055528] [ERROR]Could not connect to bumblebee daemon - is it running?

I searched the error but could only find results for Ubuntu issues.

Anybody have any ideas or need some info? (not sure which logs would contain useful info)

Graphics card is Nvidia GeForce 660M, it's worth noting that I followed the exact same setup process a week earlier and was able to optirun just fine, but after reinstalling Fedora due to a boot issue I'm now stuck

I'm a beginner so please bare that in mind when answering :)

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
1

answered 2014-06-13 01:57:45 -0500

TForsman gravatar image

When following the guide at the page: http://fedoraproject.org/wiki/Bumblebee Most users misses to install the dependencies. I never hit a issue when running these commands and reboot:

yum install -y libbsd-devel libbsd glibc-devel libX11-devel help2man autoconf git tar glib2 glib2-devel kernel-devel kernel-headers automake gcc gtk2-devel

VirtualGL

yum install VirtualGL

.

yum -y --nogpgcheck install http://install.linux.ncsu.edu/pub/yum/itecs/public/bumblebee/fedora20/noarch/bumblebee-release-1.1-1.noarch.rpm

.

yum -y install bbswitch bumblebee

.

yum -y --nogpgcheck install http://install.linux.ncsu.edu/pub/yum/itecs/public/bumblebee-nonfree/fedora20/noarch/bumblebee-nonfree-release-1.1-1.noarch.rpm

.

yum install glibc-devel

.

yum -y install bumblebee-nvidia

.

After that, I reboot and then optirun works fine. If you skip one, it might not work

edit flag offensive delete link more

Comments

This is not the issue. His laptop has secureboot and the nvidia kernel module is not signed by default as compiled by the bumblebee-nvidia script.

matth45 gravatar imagematth45 ( 2014-08-07 03:37:27 -0500 )edit
0

answered 2014-08-07 03:36:26 -0500

matth45 gravatar image

The problem is that you have a UEFI firmware and you are booting linux in a mode where the kernel requires that each kernel module that is loaded be cryptographicaly signed. When you use bumblebee-nvidia to compile the nvidia kernel driver it does it in --quiet mode, which prevents the nvidia kernel module compile script from prompting you to sign the kernel module.

Here is a dirty hack that I used to get it working on my system.

1) As root, open the script /usr/sbin/bumblebee-nvidia in your favorite editor 2) Find the line where it calls nvidia-installer -- there will be two instances, edit the --quiet out of the one that comes after the else (the non-debug line). Also remove the > redirect and everything that comes after it on the line. 3) As root, run bumblebee-nvidia. This will compile the driver. With the modified script, you will see the TUI nvidia compiler script prompts. When prompted to sign the kernel module, elect to do so. Also elect to save the .der key file. You can let it delete the private key. Towards the end it may complan about not being able to load the kernel module yet. This is fine. I also got a few errors about some libraries being write protected. This is also fine. 4) Now that the kernel module has been built and the .der public key file created, you must install the signature in your firmware. Use the mokutil utility to install the .der keyfile that was created. The key file will be located in /usr/share/nvidia and called something like nvidia-modsign-crt-XXXXXXXX.der, where XXXXXXXX is a hex code that is unique. Run mokutil like this, as root

# mokutil --import /usr/share/nvidia/nvidia-modsign-crt-XXXXXXXX.der

where you replace the XXXXXXXX with the numbers and letters that actually appear in your .der file (tab complete is your friend). You can choose any password you like here. You only have to remember it for a little while.

5) Reboot. On boot your firmware should allow you to activate the new key. I had to press a key, then select something from a menu (I forget, but it seemed obvious) then enter the password I set in step 4. Then let the system boot normally.

6) Viola! The nvidia.ko module is loaded, and the bumblebee deamon is able to run.

Now, this isn't great, because next time you update your kernel you'll have to do this again. Also, if the bumblebee package gets updated (or you want a new nvidia driver) you will have to do this again. It should really be automated, but I'm not sure what the best method of doing that is.

If you have a laptop where you can turn off secureboot, then that may be prefereable. It's not always possible though.

edit flag offensive delete link more

Comments

At the reboot, when entering the password, the keyboard setting is probably set to US QWERTY, so remember it when using non-US keyboards.

gmillet gravatar imagegmillet ( 2014-08-26 14:51:29 -0500 )edit

A variant of turning off secure boot is to disable verifications of the bootloader Shim (mokutil --disable-validation), that keeps secure boot ON without the signature verifications. more info

gmillet gravatar imagegmillet ( 2014-08-26 15:03:32 -0500 )edit

i have same problem, but i have limited English and none coding knowledge, i stuck at

2) Find the line where it calls nvidia-installer -- there will be two instances, edit the --quiet out of the one that comes after the else (the non-debug line). Also remove the > redirect and everything that comes after it on the line

Darek gravatar imageDarek ( 2015-05-20 12:38:47 -0500 )edit

mine looks like this and i dont know that to erase

enter code here   ./nvidia-installer --accept-license --silent --no-x-check --no-nouveau-check --no-recursion --opengl-libdir=$bumblebee_libdir/nvidia-bumblebee --opengl-prefix=/usr --x-library-path=$bumblebee_libdir/nvidia-bumblebee --x-prefix=/usr --x-module-path=/usr/$bumblebee_libdir/nvidia-bumblebee/xorg/modules $bumblebee_lastarg
      vidcompile=$?
Darek gravatar imageDarek ( 2015-05-20 12:40:07 -0500 )edit
0

answered 2014-06-11 02:59:46 -0500

Mehran gravatar image

updated 2014-09-27 10:07:16 -0500

Hi everyone

first of all, sorry for my bad english

I have the same problem with my asus s550c graphic driver (F20). I installed bumblebee step-by-step as described in fedora wiki. but when i entered:

optirun glxgears -info | grep "GL_VENDOR"

it reported:

[ 2866.831595] [ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.

[ 2866.831715] [ERROR]Could not connect to bumblebee daemon - is it running?

then i tried:

sudo bumblebee-nvidia --debug

it reported:

--force compile selected via /etc/sysconfig/nvidia/compile-nvidia-driver --debug mode selected. Building NVIDIA video drivers: Creating directory NVIDIA-Linux-x86_64-331.67 Verifying archive integrity... OK Uncompressing NVIDIA Accelerated Graphics Driver for Linux-x86_64 331.67..........................................................................................................................................................................................................................

ERROR: The kernel module failed to load, because it was not signed by a key that is trusted by the kernel. Please try installing the driver again, and sign the kernel module when prompted to do so.

ERROR: Unable to load the kernel module 'nvidia.ko'. This happens most frequently when this kernel module was built against the wrong or improperly configured kernel sources, with a version of gcc that differs from the one used to build the target kernel, or if a driver such as rivafb, nvidiafb, or nouveau is present and prevents the NVIDIA kernel module from obtaining ownership of the NVIDIA graphics device(s), or no NVIDIA GPU installed in this system is supported by this NVIDIA Linux graphics driver release.

Please see the log entries 'Kernel module load error' and 'Kernel messages' at the end of the file '/var/log/nvidia-installer.log' for more information.

ERROR: Installation has failed. Please see the file '/var/log/nvidia-installer.log' for details. You may find suggestions on fixing installation problems in the README available on the Linux driver download page at www.nvidia.com .

[FAILED]

and here are my last lines of '/var/log/nvidia-installer.log':

ERROR: The kernel module failed to load, because it was not signed by a key that is trusted by the kernel. Please try installing the driver again, and sign the kernel module when prompted to do so.

ERROR: Unable to load the kernel module 'nvidia.ko'. This happens most frequently when this kernel module was built against the wrong or improperly configured kernel sources, with a version of gcc that differs from the one used to build the target kernel, or if a driver such as rivafb, nvidiafb, or nouveau is present and prevents the NVIDIA kernel module from obtaining ownership of the NVIDIA graphics device(s), or no NVIDIA GPU installed in this system is supported by this NVIDIA Linux graphics driver release.

Please see the log entries 'Kernel module load error' and 'Kernel messages' at the end of the file '/var/log/nvidia-installer.log' for more information.

-> Kernel module load error: Required key not available

-> Kernel messages:

[ 46.148553] wlp3s0: RX AssocResp from f8:d1:11:b2:35:e9 (capab=0x411 status=0 aid=1)

[ 46.148600] wlp3s0: associated

[ 46.148607] IPv6: ADDRCONF(NETDEV_CHANGE): wlp3s0: link ... (more)

edit flag offensive delete link more

Comments

any help? :(

Mehran gravatar imageMehran ( 2014-06-12 01:42:58 -0500 )edit

Question Tools

2 followers

Stats

Asked: 2014-06-08 18:36:54 -0500

Seen: 9,614 times

Last updated: Sep 27 '14