How to fix long wait in grub2 loader?

asked 2014-06-06 13:22:44 -0500

Charlweed gravatar image

updated 2014-09-30 08:28:19 -0500

mether gravatar image

When I first installed Fedora 20, I had normal boot times. However, sometime over the last few updates, the boot hangs for over a minute before running the kernel. Here is the output from systemd-analyze

Startup finished in 15.312s (firmware) + 1min 24.365s (loader) + 751ms (kernel) + 2.951s (initrd) + 35.199s (userspace) = 2min 18.580s

You can read that the boot takes 1min 24.365s to load the kernel. On the screen, I see that grub starts, displays the boot entries, clears the screen and displays "Booting 'Fedora with Linux 3.14.4-200.fc20.x86_64'. My system then does nothing for a minute and a half, before running the kernel. The Kernel is 3.14.4-200.fc20.x86_64. RedHatGraphicalBoot is disabled, and the system boots to, not graphical. My kernel options are currently
$([ -x /usr/sbin/rhcrashkernel-param ] && /usr/sbin/rhcrashkernel-param || :)

This system is on an ASUS Z-77 motherboard, and boots with UEFI firmware. It dual boots with Windows 7. There are 4 SATA disk drives, all formatted GPT. All pass S.M.A.R.T. self tests. The boot partitions are on the first drive; /boot is a plain ext4 partition and /boot/efi is on a plain fat32 partition. The root filesystem is on an lvm volume comprised of 2 partitions on two drives. The other 2 of the 4 drives are paired into a mirrored dm-raid volume, which is then used as part of a single lvm data partition. That lvm volume has an ext4 filesystem, and is mounted as /home. There are a few additional unmounted partitions, on both the physical and lvm volumes.

edit retag flag offensive close merge delete



Boot once removing quiet option from kernel boot arguments and see where it wastes time.

hedayat gravatar imagehedayat ( 2014-06-07 12:45:11 -0500 )edit