Ask Your Question
3

Failed boot after LVM Volume Group Change

asked 2014-06-04 15:12:46 -0500

kova78 gravatar image

updated 2014-09-28 18:14:57 -0500

mether gravatar image

Hi Everyone,

I have changed my LVM - Volume Group name and now my system refuses to boot because it is still looking for the old name.

Can anyone help me to fix this?

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
1

answered 2014-06-04 15:41:23 -0500

hedayat gravatar image

In boot menu, select the Fedora entry and press e to enter edit mode. Then, go to the line started with linux, where you can find a parameter like this root=/dev/...., in which the name of the volume group should be present. Edit the line and boot Fedora with F10 (or Ctrl-X). If booted correctly, edit your /boot/grub2/grub.cfg accordingly.

edit flag offensive delete link more

Comments

Hi, it has brought me one step closer but it doesn't mount the boot file system.It says found the device. I pressed 'e' and replaced all the old naming to the new one but no change. Any additional idea?

kova78 gravatar imagekova78 ( 2014-06-04 16:57:15 -0500 )edit

Can you say how far does your boot progresses? Also, please try with the Fedora rescue entry to see if you can boot it with the same change. I'm not sure but non-rescue entries might have your volume group name hardcoded into their boot image (initramfs).

hedayat gravatar imagehedayat ( 2014-06-04 23:17:41 -0500 )edit

I am on Vmware. This is a virtual minimal install of Fedora 20. What I did was to add 5 new virtual disks to the existing VG and I changed the original 'fedora' VG name to 'Fedora20LVM' and it worked fine until I restarted it. Based on your suggestion, I modified the GRUB menu changing the name in but it only brought one new line in the boot process saying. Found /dev/mapper/Fedora20LVM but then it is just hanging and drops me to the 'dracut' prompt. I will try to do the same on the rescue menu as per your suggestion and come back to you. I did not know that changing the VG name causing such an issue...

kova78 gravatar imagekova78 ( 2014-06-05 00:55:32 -0500 )edit

Hi, I have just fixed it :)

http://oraganism.wordpress.com/2013/03/09/rename-lvm-vg-for-root-fs-lv/

You have to create a new ramdisk image. See the link.

kova78 gravatar imagekova78 ( 2014-06-05 13:16:54 -0500 )edit

THANK YOU! I had changed my VG name and without thinking rebooted, locking me out. I could not use the rescue CD because I have locked my Root account (which I will be unlocking as I do not use it directly) so getting into the system in the usual ways was not possible. Your step to change the kernel boot line worked, so far as getting me into emergency mode (took a while) at which point I had to guess which of my many passwords I used for root. Once I was in, I renamed the VG group back to the original name and BAMB, I am back in business...

Matthew Koster gravatar imageMatthew Koster ( 2018-02-20 15:50:00 -0500 )edit
2

answered 2014-06-05 14:19:41 -0500

kova78 gravatar image

I have just fixed it by booting from live CD and creating a new ramdisk image. :-)

http://oraganism.wordpress.com/2013/03/09/rename-lvm-vg-for-root-fs-lv/

edit flag offensive delete link more

Comments

@kova78 Thanks alot, I changed lvm group name of one of my VirtualBox vm's and had trouble booting it but your link after some research did the trick. You saved my day!

somethingSomething gravatar imagesomethingSomething ( 2015-05-02 18:59:10 -0500 )edit
1

answered 2015-11-10 03:55:12 -0500

updated 2016-01-18 08:13:18 -0500

Modifying fstab, updating grub.cfg and rebuilding initrd/initramfs has fixed the problem in my case (openSUSE 13.1).

Boot into a Linux live media (in my case it was Manjaro) and run the following commands (as root) to mount the logical volume and all the necessary filesystems:

mount /dev/mapper/vgname-lvname /mnt
mount --bind /dev /mnt/dev
mount --bind /proc /mnt/proc
mount --bind /sys /mnt/sys

Note: Replace vgname and lvname with the names of your volume group and logical volume.

Enter chroot environment (again, run the command as root):

chroot /mnt

Firstly, we need to modify the fstab file. You can use whatever tool you like. The idea is to replace the old volume group and logical volume names with the new ones. The quickest way is to use sed:

sed -i -e 's/oldvgname-oldlvname/newvgname-newlvname/g' /etc/fstab

Note: Replace oldvgname, oldlvname, newvgname and newlvname with the appropriate names.

Then you need to update the GRUB configuration file (grub.cfg). You can either edit the file manually or regenerate it with grub-mkconfig. I prefer the last one:

grub-mkconfig -o /boot/grub/grub.cfg

Now we need to rebuild initrd:

mkinitrd -f /boot/initrdimage

Note: Replace initrdimage with the name of the initrd image. In my case, there's a symlink named initrd that points to the appropriate file, but if there's none, use the name of the image file (it should look something like this: initrd-3.16.7-24-default).

Wait until it's finished.

Exit out of the chroot environment:

exit

Finally, unmount the filesystems and reboot (run the commands as root):

umount -a
reboot

After that, the system should load normally.

Some links I found useful:

  1. Problem with boot after rename in LVM — FedoraForum.org
  2. Rename LVM Volume Group Holding Root File System Volume — ORAganism
edit flag offensive delete link more

Question Tools

Stats

Asked: 2014-06-04 15:12:46 -0500

Seen: 12,733 times

Last updated: Jan 18 '16