How to I get my image to load with secure boot?

asked 2014-05-27 15:53:23 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

boot loader has not verified loaded image

I have Fedora 20 installed on external USB 3.0 HD. I boot it with a Lenovo g780 in secure boot, efi enabled.

My problem is that when I first boot, holding down f12 to get the boot menu. I see only an option to boot the external drive. So I select it and then see the grub boot screen. From there I select my Fedora 20 option and hit enter. Then I get an error "boot loader has not verified loaded image" and I think it says system compromized, haulting. Then it shuts down the computer. The next time I power up and hold f12 the boot menu shows not only the external drive, but also an option called Fedora. So I select Fedora and it bring up grub and I'm able to boot as usual. Does anyone have any idea why I have to constantly boot twice to get Fedora to work?

contents of /boot

config-3.13.10-200.fc20.x86_64
config-3.14.2-200.fc20.x86_64
config-3.14.3-200.fc20.x86_64
efi
extlinux
GRUB
grub2
initramfs-0-rescue-65be47db383c4dc2b45785ab3039d930.img
initramfs-3.13.10-200.fc20.x86_64.img
initramfs-3.14.2-200.fc20.x86_64.img
initramfs-3.14.3-200.fc20.x86_64.img
initrd-plymouth.img
lost+found
System.map-3.13.10-200.fc20.x86_64
System.map-3.14.2-200.fc20.x86_64
System.map-3.14.3-200.fc20.x86_64
vmlinuz-0-rescue-65be47db383c4dc2b45785ab3039d930
vmlinuz-3.13.10-200.fc20.x86_64
vmlinuz-3.14.2-200.fc20.x86_64
vmlinuz-3.14.3-200.fc20.x86_64

contents of /efi is EFI

contents of /boot/efi/EFI

 BOOT   fedora

contents of /boot/efi/EFI/BOOT

  BOOTX64.EFI  fallback.efi

contents of /boot/efi/EFI/fedora

BOOT.CSV  gcdx64.efi  grubx64.efi     shim.efi
fonts     grub.cfg    MokManager.efi  shim-fedora.efi

contents of /boot/grub2

grub.cfg  grubenv  themes  unicode.pf2

contents of /boot/GRUB

grubenv  themes

If I boot in insecure mode this is what I see breifly before the system boots.

System BootOrder not found. Initializing defaults. 
device path: *"\fedora\shim.efi"
creating boot entry "Boot0007" with label "Fedora" for file "\EFI\fedora\shim.efi" booting in insecure mode

So far I have tried reinstalling grub2 package and updating grub configuration.

edit retag flag offensive close merge delete

Comments

Go to the BIOS boot menu, and make Fedora the first one.

abadrinath gravatar imageabadrinath ( 2014-08-02 21:42:06 -0500 )edit