Ask Your Question
0

Screen flickering (only on desktop) with Fedora 20, but why?

asked 2014-05-26 05:31:15 -0600

emblin gravatar image

updated 2014-06-03 02:06:22 -0600

I'm using Fedora 20 and since I returned from the weekend, my screen flickers very fast. This occurs only on the desktop (excluding the menubar, with the fedora-menu and the clock, etc.) and the explorer, programs are not affected of this. Selecting anything on the desktop is not possible, probably it's cleaning or refreshing all the time.

I can't think of applying any updates on last use, but today I installed all of the fedora updates and brought the BIOS to the newest version, which didn't solve the problem.

Has anyone an idea where this comes from? (If further information is needed, please let me know.)

[Edit:] It has something to do with the background, since disabling the picture and just use a "black screen" it doesn't make any troubles anymore.

Update:

the output of

lspci -k | grep -A3 VGA

is

00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06)
    Subsystem: Fujitsu Technology Solutions Device 11e7
    Kernel driver in use: i915
    Kernel modules: i915

I'm using fedora 20 with LXDE

edit retag flag offensive close merge delete

Comments

This output of this command should show what graphics card you have:

lspci -k | grep -A3 VGA

also which desktop environment are you using?

Ahmad Samir gravatar imageAhmad Samir ( 2014-06-02 09:25:41 -0600 )edit

Pardon me, I forgot about this. Have a look at Update in the top post

emblin gravatar imageemblin ( 2014-06-03 02:07:18 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted
1

answered 2014-06-03 05:37:05 -0600

NickTux gravatar image

updated 2014-06-03 11:26:25 -0600

As you have such new Intel Card (4th Gen Core) try to enable the SNA acceleration and also the TearFree option, might help.

First make sure that the folder /etc/X11/xorg.conf.d/ exist. ls /etc/X11/xorg.conf.d/ should return some values, or nothing, but if it will returns No such file or directory you have to create the directory with sudo mkdir /etc/X11/xorg.conf.d .

Now, execute the following command, as one command in your terminal (no matter if appears here as 3 lines). Copy-paste from here to your terminal.

echo -e 'Section "Device"\n    Identifier  "Intel Graphics"\n    Driver      "intel"\n    Option      "AccelMethod"  "sna"\n    Option      "TearFree"    "true"\nEndSection' | sudo tee /etc/X11/xorg.conf.d/20-intel.conf

It should ask for you password and after you write it (correctly), it should return this result

Section "Device"
    Identifier  "Intel Graphics"
    Driver      "intel"
    Option      "AccelMethod"  "sna"
    Option      "TearFree"    "true"
EndSection

Now, restart the display manager or restart the PC and see the results, see if the problem fixed.

To restart the display manager, depends on which of them you are using. A general service , usually a symbolic link to the appropriate DM, is display-manger.service.

Hit Ctrl+Alt+F2 , login with username and password and give the following commands

sudo systemctl stop display-manager.service
sudo systemctl start display-manager.service
edit flag offensive delete link more

Comments

Thank you for that precsice answer. Everything worked fine until

sudo systemctl stop lightdm
sudo systemctl start lightdm

(I tried with gdm and lxdm too.) I get these 2 error messages:

sudo systemctl start lightdm
Failed to issue method call: Unit lightdm.service failed to load: No such file or directory.

sudo systemctl stop lightdm
Failed to issue method call: Unit lightdm.service not loaded.

I'm sorry if I have to ask again but this commands or error messages don't tell me anything

emblin gravatar imageemblin ( 2014-06-03 09:23:29 -0600 )edit

You have to find the display manager you are using. Try these commands sudo systemctl stop display-manager.service and sudo systemctl start display-manager.service

NickTux gravatar imageNickTux ( 2014-06-03 11:25:11 -0600 )edit

That didn't help too. I don't see clearly how this would solve the problem, since this is done during reboot and when doing this, the problem still consists.

emblin gravatar imageemblin ( 2014-06-04 01:26:33 -0600 )edit

To make the X server pick up/apply setting in .conf files in /etc/X11/ you can simply log out -> log in or reboot, either of which restart the X server.

A shot in the dark, if you have xorg-x11-glamor, try uninstalling it and restart the X server.

Ahmad Samir gravatar imageAhmad Samir ( 2014-06-08 07:56:19 -0600 )edit
0

answered 2014-10-27 05:43:49 -0600

pereyrdi gravatar image

updated 2014-10-27 05:44:54 -0600

Same issue for me, after do an update in a fresh install the screen start to flashing

lspci -k | grep -A3 VGA 01:05.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RS690M [Radeon Xpress 1200/1250/1270] Subsystem: Toshiba America Info Systems Device ff00 Kernel driver in use: radeon Kernel modules: radeon

any idea? thanksss

edit flag offensive delete link more
0

answered 2015-02-05 09:58:19 -0600

SpaceInvaders gravatar image

If you're still having this problem I'd strongly urge you to upgrade to Fedora 21 which has updated Intel video support that may address your issue.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-05-26 05:31:15 -0600

Seen: 5,035 times

Last updated: Feb 05 '15