Ask Your Question
0

Fedora 20 Hangs on Boot after Nvidia Quadro 2000M Drivers Install

asked 2014-05-15 13:17:34 -0500

felixmc gravatar image

I recently installed Fedora 20 (x64) on my Lenovo W520 machine with a Nvidia Quadro 2000M graphics card.

Everything worked fine, except for my external monitor which was always laggy/glitchy. I thought this would be fixed if I installed my graphics card drivers, so I downloaded them from Nvidia's site (which was just a shell script I had to run).

However, now when it boots I get the to the fedora boot logo, and then it crashes and goes to a text screen seemingly showing a log of services starting up (like Account Manager, etc).

I can use ALT + Function keys to start a new tty session and use my machine, but as you might imagine it's a lot less convenient without a GUI. I tried running init 5, but it just flashes the boot screen logo again and hangs there.

I found a lot of people having the same issues online with Nvidia GeForce graphics cards, but because I use different drivers and installed the ones from Nvidia's site, none of the solutions seem to apply to me.

My dekstop environment is Gnome 3. I would appreciate any help in getting my GUI back.

edit retag flag offensive close merge delete

Comments

Remove the drivers from nvidia's site and install them from rpmfusion. There are many questions here with instructions for you.

randomuser gravatar imagerandomuser ( 2014-05-15 19:50:19 -0500 )edit

any pointers on how would I go about uninstalling the nvidia drivers (besides hunting down the files manually and removing them)? I tried re-running the shell script, but it had not uninstall options.

felixmc gravatar imagefelixmc ( 2014-05-15 20:22:28 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2014-07-03 12:58:35 -0500

jwboyer gravatar image

Fedora doesn't provide or support the proprietary Nvidia drivers. As said in the first comment, there are many existing questions on how to install them if you really must.

edit flag offensive delete link more
0

answered 2014-07-03 16:02:16 -0500

NickTux gravatar image

As you cannot boot into GUI mode, you have to try from a TTY and uninstall the Nvidia drivers, which you manually installed from Nvidia's site. Nvidia provides an uninstall script also.

So, hit Ctrl+Alt+F3 and login there with your username and password. Then login as the super-user (root)

su -

then find and execute the installation .run file , but this time with the --uninstall switch

./NVIDIA-Linux-****-****.run --uninstall

replace the asterisks with the actual numbers. You can use the TAB completion feature here to auto-complete the name

./NVIDIA-<TAB><TAB>

If you don't have the install script

an uninstall command(script also I think) is registered during installation, but I'm not very sure about this. So try (as root)

nvidia-uninstall

After that, remove any nvidia related files from /etc/X11/ directory , connect and list the files first , then identify any file with nvidia in name and remove it.

cd /etc/X11/ 
ls 
rm <FILES with nvidia in name>

After that, you should re-install some components

yum reinstall xorg-x11-drv-nouveau mesa-libGL mesa-dri-drivers

Then reboot your PC and hopefully you should be fine, and the nouveau module should be loaded.

If you want the closed source Nvidia driver, better is to do from RPM Fusion repository. See here how to install/enable the repo - choose the command line option

After the installation of RPM Fusion repo, run

sudo yum install xorg-x11-drv-nvidia

this will install the latest nvidia driver. If you want a specific version for your card, you should search with the TAB completion feature again, and list all the available

sudo yum install xorg-x11-drv-nvidia-<TAB><TAB>
edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-05-15 13:17:34 -0500

Seen: 2,351 times

Last updated: Jul 03 '14