Ask Your Question
0

i want to install rcssmonitor_frameview-14.0.0.tar.gz and i use this command in terminal :

asked 2014-04-30 18:55:58 -0500

fbikamal gravatar image

updated 2014-05-01 11:51:29 -0500

mohanprakash gravatar image

i want to install rcssmonitor_frameview-14.0.0.tar.gz and i use this command in termianal : tar xzvf rcssmonitor_frameview-14.0.0.tar.gz but it say's that : tar (child): rcssmonitor_frameview-14.0.0.tar.gz: Cannot open: No such file or directory tar (child): Error is not recoverable: exiting now tar: Child returned status 2 tar: Error is not recoverable: exiting now

but file is exist ! it's on my download help me

edit retag flag offensive close merge delete

Comments

Have you looked at the packages already in the repo, yum search rcss ?

randomuser gravatar imagerandomuser ( 2014-05-01 00:41:29 -0500 )edit

@randomuser i do now and it show me all pakeges that contain rcss..how can i install that ?

fbikamal gravatar imagefbikamal ( 2014-05-01 03:55:07 -0500 )edit

yum install $packagename - substitute the name of the package you want to install for $packagename. This is the supported way to install software on Fedora - the GUI tools don't show all packages, but they use the same repositories.

randomuser gravatar imagerandomuser ( 2014-05-01 11:00:50 -0500 )edit

thanks alot @randomuser but it says that : You need to be root to perform this command. i went to root folder and it's says i dont have permission .... i run fedora on VMware on win 7 ! but i think it has no effect on permissions....

fbikamal gravatar imagefbikamal ( 2014-05-02 00:31:43 -0500 )edit

Yes, you need to be root to change the system configuration; regular users can only change user configuration. Try: su -c 'yum install $packagename' with the root password. If you configured your user as an administrator, use sudo yum install $packagename with your user password.

randomuser gravatar imagerandomuser ( 2014-05-02 14:53:03 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-04-30 20:51:26 -0500

Try typing the full path of the file. For example, if your username is "user" and the file is in your home directory, type: tar -xzvf /home/user/rcssmonitor_frameview-14.0.0.tar.gz.

Also, when you are typing your filenames and they are long and complex, use tab completion to ensure that the command line understands you. If you type a unique portion of the name of the file, strike tab, and the machine does not complete your filename for you, it doesn't know what you're referencing for some reason.

With a full pathname, you should take any doubt out of the process. The rest of your command syntax seems sound.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2014-04-30 18:55:58 -0500

Seen: 426 times

Last updated: May 01 '14